libHotBackup.so fails to load on Ubuntu Yakkety 64-bit, debug build

Bug #1654501 reported by Laurynas Biveinis on 2017-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
High
Vlad Lesin
5.7
Fix Released
High
Vlad Lesin

Bug Description

This started appearing after https://github.com/percona/percona-server/commit/b8f60d57b34ac29cc914c871f86f0fe0d419d8c7.

On Ubuntu Yakkety 64-bit, debug build, the TokuDB hot backup testcases fail with:

tokudb.backup.tokudb_backup_exclude w1 [ fail ]
        Test ended at 2016-12-30 15:34:42

Server log is:
2016-12-30 18:34:42 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
/mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/debug/Host/ubuntu-yakkety-64bit/build/sql/mysqld-debug: symbol lookup error: /mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/debug/Host/ubuntu-yakkety-64bit/build/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/libHotBackup.so: undefined symbol: _ZNSt6vectorIP11descriptionSaIS1_EE12emplace_backIIS1_EEEvDpOT_
safe_process[1879]: Child process: 1881, exit: 127

Recently-merged tokudb.backup.innodb_use_native_aio_enabled is affected too

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-1045

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers