systemd mysql.service start hangs forever

Bug #1635364 reported by johan on 2016-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.7
Fix Released
Undecided
EvgeniyPatlan

Bug Description

Hi,

I think the post script called by the systemd script is problematic.

I have the following

percona-server-server-5.7 5.7.14-8-1.xenial

In /lib/systemd/system/mysql.service the

ExecStartPost=/usr/share/mysql/mysql-systemd-start post

is eventually called.

However, it does not terminate b/c

pinger () {
        while /bin/true ; do
                sleep 1
                mysqladmin ping >/dev/null 2>&1 && break
        done
}

tries to ping 4-ever to the mysql server.

Now if you mistype a configuration variable, eg:

max_connection=200

(instead of the correct max_connections=200)

And do a

 sudo systemctl restart mysql

the systemd script will hang forever.

Tags: pkg Edit Tag help
tags: added: pkg
Changed in percona-server:
assignee: nobody → EvgeniyPatlan (evgeniy-patlan)
Revision history for this message
EvgeniyPatlan (evgeniy-patlan) wrote :
Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3582

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers