INFORMATION_SCHEMA.INNODB_CHANGED_PAGES queries needlessly read potentially incomplete bitmap data past the query range

Bug #1625466 reported by Laurynas Biveinis on 2016-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Medium
Laurynas Biveinis
5.6
Fix Released
Medium
Laurynas Biveinis
5.7
Fix Released
Medium
Laurynas Biveinis

Bug Description

This is different from bug 1620532.

On PS 5.6 trunk:

innodb.percona_changed_page_bmp_debug w1 [ fail ]
        Test ended at 2016-09-15 14:14:47

CURRENT_TEST: innodb.percona_changed_page_bmp_debug
mysqltest: At line 177: query 'reap' failed: 1012: Can't read record in system table
...
2016-09-15 17:14:47 22420 [ERROR] InnoDB: simulating bitmap write error in log_online_write_bitmap_page
2016-09-15 17:14:47 22420 [Warning] InnoDB: changed page bitmap file './ib_modified_log_2_8608342.xdb' does not contain a complete run at the end.
...

tags: added: bitmap ci

This is caused by the INNODB_CHANGED_PAGES iterator reading one more page past the query range and then stopping the iteration by comparing its start LSN to range end LSN. If that page happens to be corrupted, it would needlessly fail the query with a "Can't find a system record".

summary: - Test innodb.percona_changed_page_bmp_debug is unstable (failure to find
- system record)
+ INFORMATION_SCHEMA.INNODB_CHANGED_PAGES queries needlessly read
+ potentially incomplete bitmap data past the query range

Seen on 5.5 too

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-1744

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers