KILL QUERY not behaving consistently and will hang in some cases

Bug #1621046 reported by Laurynas Biveinis on 2016-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Won't Fix
Medium
Unassigned
5.6
Fix Released
Medium
Laurynas Biveinis
5.7
Invalid
Undecided
Unassigned

Bug Description

On 5.6 trunk:

main.show_check w4 [ fail ]
        Test ended at 2016-08-26 19:30:43

CURRENT_TEST: main.show_check
mysqltest: At line 1223: query 'SHOW CREATE TABLE non_existent' failed with wrong errno 1146: 'Table 'test.non_existent' doesn't exist', instead of 1317...

This could be caused by the server still cleaning up the previous executed statement by the time KILL QUERY for that thread arrives, resetting kill flag before SHOW CREATE TABLE starts executing.

Backporting the fix for https://bugs.mysql.com/bug.php?id=45679 would address this and also improve KILL QUERY behavior in general.

3f5ccb3 BUG#16457803 - MAIN.SHOW_CHECK UNSTABLE ON PB2
33eba69 BUG#16457803 - MAIN.SHOW_CHECK UNSTABLE ON PB2
1ff551e BUG#11790057 KILL QUERY WILL AFFECT THE NEXT COMMAND INCORRECTLY Bug#11754124:KILL QUERY NOT BEHAVING CONSISTENTLY AND WILL HANG IN SOME CASES

tags: added: upstream
summary: - Test show_check fails intermittently
+ KILL QUERY not behaving consistently and will hang in some cases

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3551

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.