MTR does not register unit test failures with Subunit

Bug #1608437 reported by Laurynas Biveinis on 2016-08-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Invalid
Undecided
Laurynas Biveinis

Bug Description

E.g. http://jenkins.percona.com/job/percona-server-5.5-trunk/612/BUILD_TYPE=debug,Host=ubuntu-trusty-64bit/ is a blue dot, indicating all tests passed, however the log for this run says otherwise:

00:36:18.175 unit_tests w0 [ fail ]
...

This is probably caused by a missed mtr_report_test_subunit call in unit test runner.

Tags: ci Edit Tag help
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers