Test rpl.rpl_concurrency_error is unstable

Bug #1607671 reported by Laurynas Biveinis on 2016-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

On 5.5:

rpl.rpl_concurrency_error 'stmt' w4 [ fail ]
        Test ended at 2016-07-29 03:11:32

CURRENT_TEST: rpl.rpl_concurrency_error
mysqltest: In included file "./include/rpl_diff.inc":
included from ./include/rpl_diff.inc at line 113:
At line 113: command "diff_files" failed with error 1. my_errno=175

The result from queries just before the failure was:
< snip >
master-bin.000001 # Query # # use `test`; UPDATE t SET f = 'gray 1' WHERE i = 3
master-bin.000001 # Xid # # COMMIT /* XID */
master-bin.000001 # Query # # BEGIN
master-bin.000001 # Query # # use `test`; UPDATE t SET f = 'dark blue 1' WHERE f = 'red'
master-bin.000001 # Query # # use `test`; INSERT INTO t VALUES (6 + (1 * 10),"brown")
master-bin.000001 # Xid # # COMMIT /* XID */
include/rpl_diff.inc
include/rpl_diff.inc
--- /mnt/workspace/percona-server-5.5-param/BUILD_TYPE/release/Host/ubuntu-wily-64bit/mysql-test/var/4/tmp/_rpl_diff_server-2.tmp 2016-07-29 10:11:32.081956613 +0300
+++ /mnt/workspace/percona-server-5.5-param/BUILD_TYPE/release/Host/ubuntu-wily-64bit/mysql-test/var/4/tmp/_rpl_diff_server-1.tmp 2016-07-29 10:11:32.069956613 +0300
@@ -2,8 +2,8 @@
 2016-07-29 10:11:23 updated t: red -> magenta
 2016-07-29 10:11:23 updated t: yelow -> yellow 2
 2016-07-29 10:11:25 brown
-2016-07-29 10:11:25 updated t: red -> dark blu
 2016-07-29 10:11:25 updated t: yellow 2 -> gray 2
+2016-07-29 10:11:26 updated t: red -> dark blu
 2016-07-29 10:11:27 brown
 2016-07-29 10:11:27 updated t: gray 2 -> yellow 1
 2016-07-29 10:11:27 updated t: red -> magenta

More results from queries before failure can be found in /mnt/workspace/percona-server-5.5-param/BUILD_TYPE/release/Host/ubuntu-wily-64bit/mysql-test/var/4/log/rpl_concurrency_error.log

It appears that this is caused by diffing the result of the trigger log tables, where triggers run on the master and slave independently, and so may happen to get different timestamps for the same event. The timestamps should be replaced by logical ones, i.e. autoincrement id

This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers