The proxies_priv table is not replicated

Bug #1583233 reported by monty solomon on 2016-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Invalid
Undecided
Unassigned
5.7
Fix Released
High
Unassigned

Bug Description

Proxies added via the GRANT PROXY statement or via INSERT statements to the proxies_priv table are not replicated to the slaves.

Version 5.7

Created upstream https://bugs.mysql.com/bug.php?id=81424

tags: added: upstream
Revision history for this message
monty solomon (monty+launchpad) wrote :

Upstream hasn't fixed this bug. Any chance you can fix it in PS?

Changed in percona-server:
assignee: nobody → Muhammad Irfan (muhammad-irfan)
Revision history for this message
Muhammad Irfan (muhammad-irfan) wrote :

I'm able to replicate this on Percona Server 5.7.18 that PROXY privileges are not being replicated to slave.

Changed in percona-server:
assignee: Muhammad Irfan (muhammad-irfan) → nobody
status: New → Confirmed
Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :

Muhammad, what about 5.5 and 5.6?

Monty, the upstream bug has a regression tag - in which versions has this worked before?

Revision history for this message
monty solomon (monty+launchpad) wrote :

It works in versions prior to 5.7.

My understanding is that they fixed it in 8.0 and will backport the fix to 5.7.

tags: added: regression
Revision history for this message
Muhammad Irfan (muhammad-irfan) wrote :
Download full text (4.2 KiB)

Yeah, It works before 5.7, I tested it with Percona Server 5.5 and 5.6 but couldn't reproduced same problem.

master [localhost] {root} ((none)) > SHOW VARIABLES LIKE '%version%';
+-------------------------+------------------------------------------------------+
| Variable_name | Value |
+-------------------------+------------------------------------------------------+
| innodb_version | 5.6.36-rel82.0 |
| protocol_version | 10 |
| slave_type_conversions | |
| tls_version | TLSv1.1,TLSv1.2 |
| version | 5.6.36-82.0-log |
| version_comment | Percona Server (GPL), Release 82.0, Revision 58e846a |
| version_compile_machine | x86_64 |
| version_compile_os | Linux |
+-------------------------+------------------------------------------------------+
8 rows in set (0.00 sec)

master [localhost] {root} ((none)) > show plugins;
+-----------------------------+----------+--------------------+----------------+---------+
| Name | Status | Type | Library | License |
+-----------------------------+----------+--------------------+----------------+---------+
| auth_socket | ACTIVE | AUTHENTICATION | auth_socket.so | GPL |
+-----------------------------+----------+--------------------+----------------+---------+

slave1 [localhost] {msandbox} ((none)) > show plugins;
+-----------------------------+----------+--------------------+----------------+---------+
| Name | Status | Type | Library | License |
+-----------------------------+----------+--------------------+----------------+---------+
| auth_socket | ACTIVE | AUTHENTICATION | auth_socket.so | GPL |
+-----------------------------+----------+--------------------+----------------+---------+

slave2 [localhost] {msandbox} ((none)) > show plugins;
+-----------------------------+----------+--------------------+----------------+---------+
| Name | Status | Type | Library | License |
+-----------------------------+----------+--------------------+----------------+---------+
| auth_socket | ACTIVE | AUTHENTICATION | auth_socket.so | GPL |
+-----------------------------+----------+--------------------+----------------+---------+

master [localhost] {root} ((none)) > CREATE USER 'employee_ext'@'localhost' IDENTIFIED WITH auth_socket AS 'my_auth_string';
Query OK, 0 rows affected (0.01 sec)

master [localhost] {root} ((none)) > CREATE USER 'employee'@'localhost' IDENTIFIED BY 'employee_pass';
Query OK, 0 rows affected (0.00 sec)

master [localhost] {root} ((none)) > GRANT PROXY ON 'employee'@'localhost' TO 'employee_ext'@'localhost';
Query OK, 0 rows affected (0.01 sec)

master [localhost] ...

Read more...

Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-984

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.