Comment 2 for bug 1501089

http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-10.html:

"Previously, MySQL supported only the TLSv1 protocol for encrypting secure connections. TLS support has been extended to enable a higher level of encrypted connection security:

When compiled using OpenSSL 1.0.1 or higher, MySQL supports the TLSv1, TLSv1.1, and TLSv1.2 protocols.

When compiled using the bundled version of yaSSL, MySQL supports the TLSv1 and TLSv1.1 protocols."