Intermittent rpl_err_ignoredtable failures on the 5.6 trunk

Bug #1361568 reported by Laurynas Biveinis
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Low
Laurynas Biveinis
5.1
Invalid
Undecided
Unassigned
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis

Bug Description

For example, http://jenkins.percona.com/job/percona-server-5.6-trunk/310/

has 8 failure instances. They look as follows

mysqltest: At line 50: query 'drop table t2,t3' failed: 1213: Deadlock found when trying to get lock; try restarting transaction

The relevant test snippet is

connection master1;
select get_lock('crash_lock%20C', 10);

connection master;
...
send update t2 set a = a + 1 + get_lock('crash_lock%20C', 10);

connection master1;
...
kill @id;
drop table t2,t3;
...
connection master;
# The get_lock function causes warning for unsafe statement.
--disable_warnings
--error 0,1317,2013
reap;

It looks like this is caused by the async KILL completing, and DROP TABLE processing MDL locks before the UPDATE thread checking its kill flag and releasing the locks. The easiest fix seems to be moving DROP TABLE to the master connection to be executed after reap.

Related branches

Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :

5.1 and 5.5 testcase looks the same, but not opening the bug, because I was unable to find recent occurrences of the failure there. (Not sure how would pre-MDL 5.1 failure look like neither).

tags: added: ci upstream
description: updated
Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :
Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2081

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.