libperconaserverclient18.1 doesn't include the library file

Bug #1329911 reported by Miguel Angel Nieto on 2014-06-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Critical
Tomislav Plavcic
5.1
Invalid
Undecided
Unassigned
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Critical
Tomislav Plavcic
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Undecided
Unassigned

Bug Description

# dpkg --contents libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb
drwxr-xr-x root/root 0 2014-03-06 14:05 ./
drwxr-xr-x root/root 0 2014-03-06 14:05 ./usr/
drwxr-xr-x root/root 0 2014-03-06 14:05 ./usr/share/
drwxr-xr-x root/root 0 2014-03-06 14:05 ./usr/share/doc/
drwxr-xr-x root/root 0 2014-03-06 14:05 ./usr/share/doc/libperconaserverclient18.1/
-rw-r--r-- root/root 1127 2014-03-06 13:46 ./usr/share/doc/libperconaserverclient18.1/changelog.Debian.gz
-rw-r--r-- root/root 327 2014-03-06 13:36 ./usr/share/doc/libperconaserverclient18.1/README
-rw-r--r-- root/root 30876 2014-03-06 13:36 ./usr/share/doc/libperconaserverclient18.1/copyright
-rw-r--r-- root/root 6695 2014-03-06 13:36 ./usr/share/doc/libperconaserverclient18.1/CMakeLists.txt.gz

I have checked 5.6.16 and 5.6.17.

Related branches

tags: added: i43016
Download full text (16.3 KiB)

Seems version specific. For the latest version for precise I see:

openxs@ao756:~$ dpkg --contents libperconaserverclient18.1-dev_5.6.17-66.0-608.precise_amd64.deb
drwxr-xr-x root/root 0 2014-06-08 23:50 ./
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/lib/
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/lib/x86_64-linux-gnu/
-rw-r--r-- root/root 4206786 2014-06-08 23:50 ./usr/lib/x86_64-linux-gnu/libperconaserverclient.a
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/include/
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/include/mysql/
-rw-r--r-- root/root 1979 2014-06-08 23:38 ./usr/include/mysql/my_byteorder.h
-rw-r--r-- root/root 4255 2014-06-08 23:38 ./usr/include/mysql/errmsg.h
-rw-r--r-- root/root 2821 2014-06-08 23:38 ./usr/include/mysql/my_xml.h
-rw-r--r-- root/root 10194 2014-06-08 23:38 ./usr/include/mysql/m_string.h
-rw-r--r-- root/root 4507 2014-06-08 23:38 ./usr/include/mysql/big_endian.h
-rw-r--r-- root/root 25018 2014-06-08 23:38 ./usr/include/mysql/plugin.h
-rw-r--r-- root/root 33772 2014-06-08 23:38 ./usr/include/mysql/my_global.h
-rw-r--r-- root/root 3411 2014-06-08 23:38 ./usr/include/mysql/little_endian.h
-rw-r--r-- root/root 4536 2014-06-08 23:38 ./usr/include/mysql/byte_order_generic_x86.h
-rw-r--r-- root/root 1313 2014-06-08 23:38 ./usr/include/mysql/mysql_com_server.h
-rw-r--r-- root/root 1185 2014-06-08 23:38 ./usr/include/mysql/mysql_embed.h
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/include/mysql/mysql/
-rw-r--r-- root/root 3409 2014-06-08 23:38 ./usr/include/mysql/mysql/plugin_auth.h
-rw-r--r-- root/root 1678 2014-06-08 23:38 ./usr/include/mysql/mysql/service_my_plugin_log.h
-rw-r--r-- root/root 1124 2014-06-08 23:38 ./usr/include/mysql/mysql/services.h
-rw-r--r-- root/root 25018 2014-06-08 23:38 ./usr/include/mysql/mysql/plugin.h
-rw-r--r-- root/root 4379 2014-06-08 23:38 ./usr/include/mysql/mysql/service_thd_alloc.h
-rw-r--r-- root/root 5201 2014-06-08 23:38 ./usr/include/mysql/mysql/thread_pool_priv.h
-rw-r--r-- root/root 3361 2014-06-08 23:38 ./usr/include/mysql/mysql/service_my_snprintf.h
-rw-r--r-- root/root 5595 2014-06-08 23:38 ./usr/include/mysql/mysql/client_plugin.h
-rw-r--r-- root/root 10908 2014-06-08 23:38 ./usr/include/mysql/mysql/plugin_audit.h.pp
-rw-r--r-- root/root 5348 2014-06-08 23:38 ./usr/include/mysql/mysql/service_mysql_string.h
drwxr-xr-x root/root 0 2014-06-08 23:50 ./usr/include/mysql/mysql/psi/
-rw-r--r-- root/root 1915 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_stage.h
-rw-r--r-- root/root 6571 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_table.h
-rw-r--r-- root/root 6467 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_statement.h
-rw-r--r-- root/root 2518 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_idle.h
-rw-r--r-- root/root 31203 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_socket.h
-rw-r--r-- root/root 40085 2014-06-08 23:38 ./usr/include/mysql/mysql/psi/mysql_file.h
-rw-r--r-- root/root 32260 2014-0...

tags: added: pkg
Changed in percona-server:
status: New → Incomplete

That's the dev package. The one that is empty is libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb and it should include the library. But there is no library or no symlink at all.

And it is empty also in 5.6.17. Doesn't affect 5.5 or 5.1

Yes, that is the dev package. The issue is with library package which is broken.

summary: - libperconaserverclient doesn't include the library file
+ libperconaserverclient18.1 doesn't include the library file

Confirming that's indeed the case - libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb:

fernando@host-02:~$ md5sum libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb
4dd4492ebd7280b2ee8f9a3c45757e31 libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb

fernando@host-02:~$ sudo dpkg -i libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb
[sudo] password for fernando:
dpkg: warning: downgrading libperconaserverclient18.1 from 5.6.16-64.2-569.precise to 5.6.16-64.0-553.precise.
(Reading database ... 51467 files and directories currently installed.)
Preparing to replace libperconaserverclient18.1 5.6.16-64.2-569.precise (using libperconaserverclient18.1_5.6.16-64.0-553.precise_amd64.deb) ...
Unpacking replacement libperconaserverclient18.1 ...
Setting up libperconaserverclient18.1 (5.6.16-64.0-553.precise) ...
fernando@host-02:~$ dpkg -L libperconaserverclient18.1
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libperconaserverclient18.1
/usr/share/doc/libperconaserverclient18.1/changelog.Debian.gz
/usr/share/doc/libperconaserverclient18.1/README
/usr/share/doc/libperconaserverclient18.1/copyright
/usr/share/doc/libperconaserverclient18.1/CMakeLists.txt.gz

Sorry, my fault with -dev... Confirmed.

This is how it looks for libperconaserverclient18.1 from PXC builds:

lrwxrwxrwx 1 raghavendra users 24 Jun 13 21:50 libmysqlclient.so.18 -> libmysqlclient.so.18.1.0
-rw-r--r-- 1 raghavendra users 5619609 Jun 13 21:46 libmysqlclient.so.18.1.0
lrwxrwxrwx 1 raghavendra users 20 Jun 13 21:50 libmysqlclient_r.so.18 -> libmysqlclient.so.18
lrwxrwxrwx 1 raghavendra users 24 Jun 13 21:50 libmysqlclient_r.so.18.1.0 -> libmysqlclient.so.18.1.0

from http://jenkins.percona.com/job/percona-xtradb-cluster-5.6-debian-binary/label_exp=ubuntu-precise-64bit/4/artifact/libperconaserverclient18.1_5.6.17-25.5-790.precise_amd64.deb

This looks fine for me except the libmysqlclient.so.18 symlink "libmysqlclient.so.18 -> libmysqlclient.so.18.1.0". With this symlink, it will conflict with libperconaserverclient18 (from 5.5).

However,

lrwxrwxrwx 1 raghavendra users 24 May 23 19:17 libmysqlclient.so.18 -> libmysqlclient.so.18.1.0
-rw-r--r-- 1 raghavendra users 3659800 May 23 19:17 libmysqlclient.so.18.1.0

is how it looks for libmysqlclient18 from Oracle:
https://dev.mysql.com/get/Downloads/MySQL-5.6/libmysqlclient18_5.6.19-1ubuntu14.04_i386.deb

So, the libperconaserverclient18 above should be fine.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1688

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-382

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers