hard to read history file

Bug #1296192 reported by monty solomon on 2014-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Low
Tomislav Plavcic
5.6
Fix Released
Low
Tomislav Plavcic

Bug Description

In Percona Server 5.6 the history file is no longer easy to read.

# cat .mysql_history
_HiStOrY_V2_
select\040now();
show\040slave\040status\134G
show\040processlist;
use\040information_schema
show\040tables;
SHOW\040ENGINE\040INNODB\040STATUS\134G

Server version: 5.6.16-64.1-56-log Percona Server (GPL), Release 64.1, Revision 563

Linux 2.6.32-431.el6.x86_64 #1 SMP Fri Nov 22 03:15:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

CentOS release 6.5 (Final)

monty solomon (monty+launchpad) wrote :

Here is the same history file from Percona 5.5

$ cat .mysql_history
select now();
show slave status\G
show processlist;
use information_schema
show tables;
SHOW ENGINE INNODB STATUS\G

Server version: 5.5.36-34.1-log Percona Server (GPL), Release rel34.1, Revision 642

This is easy to reproduce with Percona Server 5.6:

[openxs@chief 5.6]$ tail -10 ~/.mysql_history
select\040version();
show\040variables\040like\040'char%';
show\040create\040table\040test3\134G
alter\040table\040test3\040modify\040test_column\040varchar(10)\040charset\040utf8mb4;
show\040create\040table\040test3\134G
insert\040into\040test2\040values(unhex('f09f9884'));
insert\040into\040test3\040values(unhex('f09f9884'));
select\040*\040from\040test3;
select\040now();
select\040now(),\040now();

But it seems the problem is inherited from upstream MySQL 5.6. Had you reported it upstream already?

I've reported upstream bug for this:

http://bugs.mysql.com/bug.php?id=72108

Please, check it and add comments there if needed.

tags: added: upstream
monty solomon (monty+launchpad) wrote :

It appears that upstream stopped using readline.

Can readline be added to Percona Server?

Monty -

Please follow bug 1266386 re. readline.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2066

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.