Missing multiarch-support on Ubuntu Lucid

Bug #1291628 reported by David on 2014-03-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.1
Undecided
Unassigned
5.5
Undecided
Unassigned
5.6
High
Tomislav Plavcic

Bug Description

multiarch-support does not seem to be available on Lucid. What I am doing wrong?

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid

$ uname -a
Linux dr 2.6.32-57-server #119-Ubuntu SMP Wed Feb 19 01:11:15 UTC 2014 x86_64 GNU/Linux

$sudo aptitude install percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libperconaserverclient18.1
The following packages will be upgraded:
  percona-server-client-5.6 percona-server-server-5.6
2 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.8MB of archives. After unpacking 18.7MB will be freed.
The following packages have unmet dependencies:
  libperconaserverclient18.1: PreDepends: multiarch-support which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-server
percona-server-server-5.6

Keep the following packages at their current version:
libperconaserverclient18.1 [Not Installed]
percona-server-client-5.6 [5.6.15-rel63.0-519.lucid (now)]

Score is -9787

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.

$ sudo aptitude install multiarch-support
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
No candidate version found for multiarch-support
No candidate version found for multiarch-support
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

Tags: pkg Edit Tag help

Related branches

lp:~percona-core/percona-server/release-5.6.16-64.1
Laurynas Biveinis: Approve on 2014-03-26
Jericho Rivera (jericho-rivera) wrote :
Download full text (6.2 KiB)

I did get the same results with:

root@lucid64:/home/vagrant# aptitude install percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libperconaserverclient18.1
The following NEW packages will be installed:
  mysql-common{a}
The following packages will be upgraded:
  percona-server-client-5.6 percona-server-common-5.6 percona-server-server-5.6
3 packages upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 29.8MB/29.9MB of archives. After unpacking 18.5MB will be freed.
The following packages have unmet dependencies:
  libperconaserverclient18.1: PreDepends: multiarch-support which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
libperconaserverclient18.1 [Not Installed]
percona-server-client-5.6 [5.6.15-rel63.0-519.lucid (now)]
percona-server-server-5.6 [5.6.15-rel63.0-519.lucid (now)]

Score is -9799

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

And also tried upgrading through the following:

root@lucid64:/home/vagrant# apt-get install percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  percona-server-server-5.6: Depends: percona-server-client-5.6 (>= 5.6.16-64.0-553.lucid) but 5.6.15-rel63.0-519.lucid is to be installed
E: Broken packages

root@lucid64:/home/vagrant# dpkg --list | grep percona
ii percona-server-client 5.6.15-rel63.0-519.lucid Percona Server database client
ii percona-server-client-5.6 5.6.15-rel63.0-519.lucid Percona Server database client binaries
ii percona-server-common-5.6 5.6.15-rel63.0-519.lucid Percona Server database common files (e.g. /
ii percona-server-server 5.6.15-rel63.0-519.lucid Percona Server database server
ii percona-server-server-5.6 5.6.15-rel63.0-519.lucid Percona Server database server binaries
ii percona-server-test-5.6 5.6.15-rel63.0-519.lucid Percona Server database test suite

Tried this:

root@lucid64:/home/vagrant# apt-get upgrade percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  percona-server-client-5.6 percona-server-common-5.6 percona-server-server-5.6 percona-server-test-5.6
The following packages will be upgraded:
  percona-server-client percona-server-server
2 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 21.8kB of archives.
After this operation, 57.3kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 h...

Read more...

Jericho Rivera (jericho-rivera) wrote :
Download full text (6.3 KiB)

On Percona Server 5.5.36, an apt-get upgrade will successfully upgrade the version:

root@lucid64:/home/vagrant# aptitude install percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
The following packages are BROKEN:
  libperconaserverclient18.1 percona-server-client-5.6 percona-server-server-5.6
The following NEW packages will be installed:
  percona-server-common-5.6{a}
The following packages will be REMOVED:
  linux-headers-2.6.32-42{u} linux-headers-2.6.32-42-server{u}
The following packages will be upgraded:
  percona-server-client-5.5 percona-server-server-5.5
2 packages upgraded, 4 newly installed, 2 to remove and 2 not upgraded.
Need to get 54.0MB of archives. After unpacking 9,294kB will be used.
The following packages have unmet dependencies:
  percona-server-server-5.6: Breaks: percona-server-server-5.5 but 5.5.36-rel34.0-632.lucid is to be installed.
  percona-server-client-5.6: Breaks: percona-server-client-5.5 but 5.5.36-rel34.0-632.lucid is to be installed.
  libperconaserverclient18.1: PreDepends: multiarch-support which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
libperconaserverclient18.1 [Not Installed]
percona-server-client-5.6 [Not Installed]
percona-server-server-5.6 [Not Installed]

Score is -9857

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

root@lucid64:/home/vagrant# apt-get install percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  percona-server-server-5.6: Depends: percona-server-client-5.6 (>= 5.6.16-64.0-553.lucid) but it is not going to be installed
E: Broken packages

root@lucid64:/home/vagrant# apt-get upgrade percona-server-server-5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  percona-server-client percona-server-server
The following packages will be upgraded:
  percona-server-client-5.5 percona-server-server-5.5
2 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 24.2MB of archives.
After this operation, 16.8MB disk space will be freed.
Do you want to continue [Y/n]? y
Get:1 http://repo.percona.com/apt/ lucid/main percona-server-client-5.5 5.5.36-rel34.0-632.lucid [8,343kB]
Get:2 http://repo.percona.com/apt/ lucid/main percona-server-server-5.5 5.5.36-rel34.0-632.lucid [15.9MB]
Fetched 24.2MB in 1s (18.6MB/s)
Preconfiguring packages ...
(Reading database ... 68414 files and directories currently installed.)
Preparing to replace percona-server-client-5.5 5.5.35-rel33.0-611.lucid (usin...

Read more...

tags: added: pkg
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers