CentOS: mysql-libs conflict with server package and new client packages

Bug #1278516 reported by Raghavendra D Prabhu on 2014-02-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
High
Tomislav Plavcic
5.5
Fix Released
High
Tomislav Plavcic
5.6
Fix Released
High
Tomislav Plavcic
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Fix Released
Undecided
Unassigned
5.6
Fix Released
Undecided
Unassigned

Bug Description

Since we are moving to libperconaserverclient, packages like
perl-DBD-MySQL which require libmysqlclient.so.16 (and on which
packages like percona-toolkit and percona-xtrabackup depend on)
will install mysql-libs (they were installing
Percona-Server-share-51 or Percona-Server-shared-compat earlier) as a dependency.

http://pkgs.org/centos-6/centos-x86_64/mysql-libs-5.1.71-1.el6.x86_64.rpm.html

However, files in /usr/share/mysql/charsets/ and /usr/share/mysql/**/*.sys conflict between the server package and the mysql-libs. Because of this conflict, installation of perl-DBD-MySQL/xtrabackup/percona-toolkit etc. won't be possible.

The solution (or one of the solutions) is to use a different
prefix here - instead of /usr/share/mysql it can be
/usr/share/percona-server for PS and
/usr/share/percona-xtradb-cluster for PXC (needs to be done in
install_layout.cmake for RPM INSTALL_LAYOUT). mysql_install_db will
also need to be updated for this.

Also, Percona-Server-devel should be made to conflict with
mysql-libs (since mysql_config provided by both makes the
difference as to which library the application is built against).

Tags: pkg Edit Tag help

Related branches

summary: - mysql-libs conflict with server package
+ mysql-libs conflict with server package and new client packages
summary: - mysql-libs conflict with server package and new client packages
+ CentOS: mysql-libs conflict with server package and new client packages

Both the mysql-libs /usr/share conflict and conflict between
-devel and mysql-libs have been fixed. Also, mysql_install_db
updated appropriately.

Another update I made is that -devel and mysql-libs don't conflict. It only conflicts with mysql package from centos6 repo over mysql_config.

Set to Confirmed based on discussion with Raghu in a separate email thread. There is work in progress for PS to fix this, as far as I understand.

tags: added: pkg

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1614

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-762

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers