Problems with percona-server install Ubuntu 12.04

Bug #1217551 reported by Sergey on 2013-08-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Expired
Undecided
Unassigned

Bug Description

I'm trying to install percona-server-5.5 on my Linode ( fresh linode install of Ubuntu 12.04 64bit ).

Added apt repo and also created pin preference according to http://www.percona.com/doc/percona-server/5.5/installation/apt_repo.html

--------------------------------------

apt-get install percona-server-server-5.5 percona-server-client-5.5

--------------------------------------

OUTPUT

root@web01:~# apt-get install percona-server-server-5.5 percona-server-client-5.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  percona-server-common-5.5
Suggested packages:
  tinyca
The following NEW packages will be installed:
  percona-server-client-5.5 percona-server-common-5.5 percona-server-server-5.5
0 upgraded, 3 newly installed, 0 to remove and 58 not upgraded.
Need to get 0 B/30.7 MB of archives.
After this operation, 108 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
Selecting previously unselected package percona-server-common-5.5.
(Reading database ... 32985 files and directories currently installed.)
Unpacking percona-server-common-5.5 (from .../percona-server-common-5.5_1%3a5.5.32-rel31.0-549.precise_amd64.deb) ...
Selecting previously unselected package percona-server-client-5.5.
Unpacking percona-server-client-5.5 (from .../percona-server-client-5.5_1%3a5.5.32-rel31.0-549.precise_amd64.deb) ...
Selecting previously unselected package percona-server-server-5.5.
Unpacking percona-server-server-5.5 (from .../percona-server-server-5.5_1%3a5.5.32-rel31.0-549.precise_amd64.deb) ...
dpkg: warning: version '3.9.3-x86_64-linode33' has bad syntax: invalid character in version number
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up percona-server-common-5.5 (1:5.5.32-rel31.0-549.precise) ...
Setting up percona-server-client-5.5 (1:5.5.32-rel31.0-549.precise) ...
Setting up percona-server-server-5.5 (1:5.5.32-rel31.0-549.precise) ...
 * Stopping MySQL (Percona Server) mysqld [ OK ]

 * Percona Server is distributed with several useful UDF (User Defined Function) from Percona Toolkit.
 * Run the following commands to create these functions:

 mysql -e "CREATE FUNCTION fnv1a_64 RETURNS INTEGER SONAME 'libfnv1a_udf.so'"
 mysql -e "CREATE FUNCTION fnv_64 RETURNS INTEGER SONAME 'libfnv_udf.so'"
 mysql -e "CREATE FUNCTION murmur_hash RETURNS INTEGER SONAME 'libmurmur_udf.so'"

 * See http://www.percona.com/doc/percona-server/5.5/management/udf_percona_toolkit.html for more details

 * Starting MySQL (Percona Server) database server mysqld [fail]
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing percona-server-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tags: pkg Edit Tag help
tags: added: pkg
Download full text (5.8 KiB)

Try to reproduce it with same configuration but unable to do it.

root@localhost:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

root@localhost:~# uname -a
Linux nilnandan-VirtualBox 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
root@localhost:~#

root@localhost:~# apt-get install percona-server-server-5.5 percona-server-client-5.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libaio1 libdbd-mysql-perl libdbi-perl libmysqlclient18 libnet-daemon-perl libplrpc-perl percona-server-common-5.5
Suggested packages:
  tinyca
The following NEW packages will be installed:
  libaio1 libdbd-mysql-perl libdbi-perl libmysqlclient18 libnet-daemon-perl libplrpc-perl percona-server-client-5.5 percona-server-common-5.5
  percona-server-server-5.5
0 upgraded, 9 newly installed, 0 to remove and 581 not upgraded.
Need to get 31.6 MB/32.5 MB of archives.
After this operation, 114 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://repo.percona.com/apt/ precise/main libmysqlclient18 amd64 1:5.5.33-rel31.1-566.precise [840 kB]
Get:2 http://in.archive.ubuntu.com/ubuntu/ precise/main libdbd-mysql-perl amd64 4.020-1build2 [106 kB]
Get:3 http://repo.percona.com/apt/ precise/main percona-server-common-5.5 amd64 1:5.5.33-rel31.1-566.precise [2,748 B]
Get:4 http://repo.percona.com/apt/ precise/main percona-server-client-5.5 amd64 1:5.5.33-rel31.1-566.precise [8,496 kB]
Get:5 http://repo.percona.com/apt/ precise/main percona-server-server-5.5 amd64 1:5.5.33-rel31.1-566.precise [22.2 MB]
Fetched 31.6 MB in 1min 27s (359 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libaio1.
(Reading database ... 141891 files and directories currently installed.)
Unpacking libaio1 (from .../libaio1_0.3.109-2ubuntu1_amd64.deb) ...
Selecting previously unselected package libmysqlclient18.
Unpacking libmysqlclient18 (from .../libmysqlclient18_1%3a5.5.33-rel31.1-566.precise_amd64.deb) ...
Selecting previously unselected package libnet-daemon-perl.
Unpacking libnet-daemon-perl (from .../libnet-daemon-perl_0.48-1_all.deb) ...
Selecting previously unselected package libplrpc-perl.
Unpacking libplrpc-perl (from .../libplrpc-perl_0.2020-2_all.deb) ...
Selecting previously unselected package libdbi-perl.
Unpacking libdbi-perl (from .../libdbi-perl_1.616-1build2_amd64.deb) ...
Selecting previously unselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_4.020-1build2_amd64.deb) ...
Selecting previously unselected package percona-server-common-5.5.
Unpacking percona-server-common-5.5 (from .../percona-server-common-5.5_1%3a5.5.33-rel31.1-566.precise_amd64.deb) ...
Selecting previously unselected package percona-server-client-5.5.
Unpacking percona-server-client-5.5 (from .../percona-server-client-5.5_1%3a5.5.33-rel31.1-566.precise_amd64.deb) ...
Se...

Read more...

Changed in percona-server:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Percona Server because there has been no activity for 60 days.]

Changed in percona-server:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers