Assertion `pfs->m_idle || (state == PSI_SOCKET_STATE_IDLE)' failed when run with thread pool

Bug #1194097 reported by Sergei Glushchenko on 2013-06-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
High
Sergei Glushchenko
5.1
Invalid
Undecided
Unassigned
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
High
Sergei Glushchenko

Bug Description

Percona Server 5.6 fails with assertion

mysqld-debug: /mnt/workspace/percona-server-5.6-param/BUILD_TYPE/debug/Host/ubuntu-precise-64bit/Percona-Server/storage/perfschema/pfs.cc:5053: void set_socket_state_v1(PSI_socket*, PSI_socket_state): Assertion `pfs->m_idle || (state == PSI_SOCKET_STATE_IDLE)' failed.
16:01:18 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.
Please help us make Percona Server better by reporting any
bugs at http://bugs.percona.com/

When tun with thread pool.

Tags: tp Edit Tag help

Related branches

tags: added: tp
tags: added: 56qual
Roel Van de Paar (roel11) wrote :

--56qual as tp is beta

tags: removed: 56qual
Roel Van de Paar (roel11) wrote :

bugfix targeted for GA (review by Laurynas together with bug 1201440)

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-685

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers