the deadlock counter in PS5.6.11 is not needed

Bug #1192052 reported by zhai weixiang on 2013-06-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.1
Invalid
Undecided
Unassigned
5.5
Invalid
Undecided
Unassigned
5.6
Won't Fix
Undecided
Unassigned
5.7
Fix Released
Wishlist
Laurynas Biveinis

Bug Description

Because there is a similar counter exists in INNODB_METRICS:

mysql> select count, status, name, subsystem from INFORMATION_SCHEMA.INNODB_METRICS where name = 'lock_deadlocks';
+-------+---------+----------------+-----------+
| count | status | name | subsystem |
+-------+---------+----------------+-----------+
| 7912 | enabled | lock_deadlocks | lock |
+-------+---------+----------------+-----------+
1 row in set (0.01 sec)

It's not a bug per se for a status var to duplicate a INNODB_METRICS table counter.

We need to make a design decision whether we want to duplicate them or not, and that's the linked blueprint. Linking this bug there and closing as Opinion.

tags: added: xtradb

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2977

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers