Percona Server with XtraDB

Rpm Server package should depend on client and conflict with mysql-libs

Reported by Ignacio Nin on 2013-06-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.1
Undecided
Unassigned
5.5
Undecided
Unassigned
5.6
High
Ignacio Nin

Bug Description

When yum installing Percona-Server-server-56, the client package isn't marked for install. Furthermore, if mysql-libs is previously installed it generates a conflict:

# yum install Percona-Server-server-56

(1/2): Percona-Server-server-56-5.6.11-rc60.3.375.rhel6.x86_64.rpm | 18 MB 01:32
(2/2): Percona-Server-shared-56-5.6.11-rc60.3.375.rhel6.x86_64.rpm | 694 kB 00:05
--------------------------------------------------------------------------------------------------------------------------------Total 190 kB/s | 18 MB 01:39
Running rpm_check_debug
Running Transaction Test

Transaction Check Error:
  file /usr/share/mysql/czech/errmsg.sys from install of Percona-Server-server-56-5.6.11-rc60.3.375.rhel6.x86_64 conflicts with
file from package mysql-libs-5.1.69-1.el6_4.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of Percona-Server-server-56-5.6.11-rc60.3.375.rhel6.x86_64 conflicts with file from package mysql-libs-5.1.69-1.el6_4.x86_64
(...)

To fix this, we need to port the appropriate Conflicts: and Requires: from 5.5.

Tags: pkg Edit Tag help
tags: added: pkg
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers