Unstable test percona_bug643149

Bug #1177356 reported by Laurynas Biveinis on 2013-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Low
Laurynas Biveinis
5.1
Won't Fix
Low
Unassigned
5.5
Triaged
Low
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis

Bug Description

-# User@Host: root[root] @ localhost [] Id:<5 spaces>X
+# User@Host: root[root] @ localhost [] Id:<2 spaces>X

The problem seems to be a combination of thread id which is right-padded with spaces in output, and the testcase itself not collapsing such spaces during the result normalization.

Related branches

tags: added: ci slow-extended
description: updated

Couldn't find such failure in recent 5.1 and 5.5 trunk Jenkins runs. (Jenkins has a search box which didn't help much, manual review is very slow). Nevertheless if my patch fixes it for 5.6, will set it to Confirmed for 5.1 and 5.5 as well.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2003

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers