Comment 53 for bug 1169505

Me again.

This time, same problem on servers updated to Wheezy:

# dpkg -l | grep libmysqlclient
ii libmysqlclient18 5.5.35-rel33.0-611.wheezy amd64 Percona Server database client library

# apt-cache search libmysqlclient
libglpk0 - linear programming kit with integer (MIP) support
libcrypt-mysql-perl - Perl module to emulate the MySQL PASSWORD() function
libmysqlclient-dev - MySQL database development files
libmysqlclient18 - Percona Server database client library

Ok. So how am I supposed to used another package where there aren't any others?

# apt-cache showpkg libmysqlclient18
Package: libmysqlclient18
Versions:
5.5.35-rel33.0-611.wheezy (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/dpkg/status
                  MD5: bcc8440e50dc4f4c65b38a57b7ea31b5

5.5.33+dfsg-0+wheezy1 (/var/lib/apt/lists/security.debian.org_dists_wheezy_updates_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: 49de807663510f5f2afd3e71efe199f1
 Description Language: en
                 File: /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_wheezy_main_i18n_Translation-en
                  MD5: 49de807663510f5f2afd3e71efe199f1

5.5.31+dfsg-0+wheezy1 (/var/lib/apt/lists/ftp.fr.debian.org_debian_dists_wheezy_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: 49de807663510f5f2afd3e71efe199f1
 Description Language: en
                 File: /var/lib/apt/lists/ftp.fr.debian.org_debian_dists_wheezy_main_i18n_Translation-en
                  MD5: 49de807663510f5f2afd3e71efe199f1
[snip]

The commend lists a lots of things, including all the available versions for the package, not only the most recent one.

# apt-get install libmysqlclient18=5.5.33+dfsg-0+wheezy1
=> downgrade to the non-percona 5.5.33 package
=> SSL connection working fine

Unfortunately I can't say what the problem is with the percona package, I can only observe that the SSL connection is working fine with the regular package.
Of course it's the exact same piece of code and .pem which are used in both cases.