Percona Server with XtraDB

RPM spec doesn't restart Percona on upgrade

Reported by Mark McKinstry on 2013-04-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.5
Critical
Stewart Smith
5.6
Critical
Laurynas Biveinis
Percona XtraDB Cluster
Critical
Ignacio Nin

Bug Description

The change at https://bazaar.launchpad.net/~percona-core/percona-server/5.5/revision/472#build/percona-server.spec added a conditional, [ $1 -eq 1 ], in the %post section of the spec to fix bug #710799 .

The conditional should be around the section that creates the test DB but is around a larger section, including the section that sets the SERVER_TO_START variable. Since [ $1 -eq 1 ] will only be true for new installs, the section that sets the varialbe SERVER_TO_START is never run and the variable is never set. When it gets to part of the spec where it would restart Percona based on the SERVER_TO_START variable, it doesn't restart it since the variable was never set.

Tags: pkg Edit Tag help
tags: added: pkg
Stewart Smith (stewart) wrote :

This is pretty serious (especially when combined with automatic updates on a server). We should reissue packages with this fix.

I have not checked if this affects 5.6 - i'm told it doesn't affect 5.1

Changed in percona-server:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Stewart Smith (stewart)
Ignacio Nin (ignacio-nin) wrote :

Confirmed not to affect 5.1.

Confirmed to affect PXC, added to the bug list
5.6 is not yet affected, but it will become affected as soon as revno 472 from 5.5 is merged.

Rebasing Stewart's fix to revno 472 so it can be merged easily to PXC and in the future to 5.6.

Changed in percona-xtradb-cluster:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Ignacio Nin (ignacio-nin)
Changed in percona-xtradb-cluster:
status: Confirmed → Fix Committed
milestone: none → 5.5.30-24.8
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers