Percona Server with XtraDB

RPM: Different versions of Percona-Server should conflict

Reported by Ignacio Nin on 2013-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.1
High
Ignacio Nin
5.5
High
Ignacio Nin
5.6
High
Ignacio Nin
Percona XtraDB Cluster
Medium
Ignacio Nin

Bug Description

Percona-Server-client-51 and Percona-Server-client-55 don't conflict at the package level, so yum doesn't detect that they shouldn't be installed together, see below.

These combinations are also in theory possible for yum:
Percona-SQL-client-50 Percona-Server-client-51
Percona-SQL-client-50 Percona-Server-client-55
Percona-SQL-client-50 Percona-Server-client-56
Percona-Server-client-51 Percona-Server-client-56
Percona-Server-client-55 Percona-Server-client-56
Percona-SQL-server-50 Percona-Server-server-51
Percona-SQL-server-50 Percona-Server-server-55
Percona-SQL-server-50 Percona-Server-server-56
Percona-Server-server-51 Percona-Server-server-55
Percona-Server-server-51 Percona-Server-server-56
Percona-Server-server-55 Percona-Server-server-56

and so on. The devel and test packages are also affected.

All these packages should conflict at the package level, ideally the 5.1 packages conflict with the 5.0 packages, the 5.5 packages with both 5.0 and 5.1, etc..

Furthermore, Percona-Server-shared-55 and Percona-Server-shared-56 should also conflict since they use the same version of libmysqlclient.so library.

# yum -qy install Percona-Server-client-55 Percona-Server-client-51
Loaded plugins: fastestmirror, presto
Ignored option -q, -v, -d or -e (probably due to merging: -yq != -y -q)
Loading mirror speeds from cached hostfile
 * base: mirrors.dcarsat.com.ar
 * epel: epel.gtdinternet.com
 * extras: mirrors.dcarsat.com.ar
 * updates: mirrors.dcarsat.com.ar
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-Server-client-51.x86_64 0:5.1.68-rel14.5.513.rhel6 will be installed
---> Package Percona-Server-client-55.x86_64 0:5.5.30-rel30.1.465.rhel6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================
 Package Arch Version Repository Size
==================================================================================================================================================
Installing:
 Percona-Server-client-51 x86_64 5.1.68-rel14.5.513.rhel6 percona 911 k
 Percona-Server-client-55 x86_64 5.5.30-rel30.1.465.rhel6 percona 7.0 M

Transaction Summary
==================================================================================================================================================
Install 2 Package(s)

Total size: 7.9 M
Installed size: 34 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test

Transaction Check Error:
  file /usr/bin/hsclient conflicts between attempted installs of Percona-Server-client-51-5.1.68-rel14.5.513.rhel6.x86_64 and Percona-Server-client-55-5.5.30-rel30.1.465.rhel6.x86_64
  file /usr/bin/my_print_defaults conflicts between attempted installs of Percona-Server-client-51-5.1.68-rel14.5.513.rhel6.x86_64 and Percona-Server-client-55-5.5.30-rel30.1.465.rhel6.x86_64
  file /usr/bin/mysql conflicts between attempted installs of Percona-Server-client-51-5.1.68-rel14.5.513.rhel6.x86_64 and Percona-Server-client-55-5.5.30-rel30.1.465.rhel6.x86_64
(...)

Changed in percona-xtradb-cluster:
assignee: nobody → Ignacio Nin (ignacio-nin)
importance: Undecided → Medium

@Ignacio:
Does this apply to PXC as well?

Changed in percona-xtradb-cluster:
status: New → Triaged
milestone: none → 5.5.30-24.8
Ignacio Nin (ignacio-nin) wrote :

PXC correctly conflicts with 5.0, 5.1 and 5.5, but it doesn't conflict against 5.6.

Since the rule is 5.x ignores 5.y and 5.y conflicts 5.x if x < y, we've got a little bit of an assimetry here -- either can conlict with the other.

Let's choose PXC to conflict against 5.6 and have 5.6 ignore PXC, this way considering PXC as a "latter product" than any Percona Server version.

Changed in percona-xtradb-cluster:
status: Triaged → In Progress
Changed in percona-xtradb-cluster:
status: In Progress → Fix Committed
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers