Remove malloc() from read_view_create_low()

Bug #1131187 reported by Alexey Kopytov on 2013-02-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
High
Alexey Kopytov
5.1
Won't Fix
Undecided
Unassigned
5.5
Fix Released
High
Alexey Kopytov
5.6
Fix Released
High
Alexey Kopytov

Bug Description

read_view_create_low() is called on every transaction start and allocates memory for the read view created in read_view_open_now().

The problem is that the heap for that allocation is emptied on each commit and thus read view memory is reallocated on the next transaction. Memory profiling shows that memory allocated by read_view_create_low() amount to almost 100% of all allocations made by InnoDB in sysbench read-only tests.

Related branches

Alexey Kopytov (akopytov) wrote :

I will port it to 5.6 myself.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-636

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.