Embedded server build is broken in PS 5.5

Bug #1126242 reported by Ovais Tariq on 2013-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.1
Invalid
Undecided
Unassigned
5.5
Fix Released
Low
Przemyslaw Skibinski
5.6
Invalid
Undecided
Unassigned
5.7
Invalid
Undecided
Unassigned

Bug Description

I am unable to compile the source tarball available here: http://www.percona.com/redir/downloads/Percona-Server-5.5/Percona-Server-5.5.29-29.4/source/Percona-Server-5.5.29-rel29.4.tar.gz

I am trying to compile it as follows:
cmake . -DBUILD_CONFIG=mysql_release
make

The output of 'make' can be seen here: http://paste2.org/p/2877176

Looks like (based on discussion) mysql_release includes Embedded in it, which causes this.

The workaround for now is to pass -DWITH_EMBEDDED_SERVER=OFF in addition to other cmake flags.

Changed in percona-server:
status: New → Confirmed
summary: - I am unable to compile the Percona 5.5.29-rel29.4 source tarball
+ Embedded server is broken in PS 5.5
summary: - Embedded server is broken in PS 5.5
+ Embedded server build is broken in PS 5.5
tags: added: regression

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2893

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers