Percona Server with XtraDB

Percona 5.5 fails to install on a vanilla Ubuntu 12.04 server

Reported by Christopher Kuttruff on 2013-01-23
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Percona Server
Critical
Ignacio Nin

Bug Description

I found similar (but outdated posts (eg: https://bugs.launchpad.net/percona-server/+bug/877018)) on some other bug tickets, though they seemed to be marked as resolved. My apologies if I've missed something, but I do believe I've followed the installation instructions on a base system, so I'm confused as to why these errors would be occurring.

Thanks for your time.

Followed the instructions listed on this page exactly:
http://www.percona.com/doc/percona-server/5.5/installation/apt_repo.html

when running apt-get install command:

# apt-get install percona-server-server-5.5 percona-server-client-5.5
....

The following packages have unmet dependencies:
 percona-server-client-5.5 : Depends: libmysqlclient18 (>= 5.5.28-rel29.3-388.precise) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

More info when running aptitude install:

# aptitude install percona-server-server-5.5 percona-server-client-5.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 percona-server-client-5.5 : Depends: libmysqlclient18 (>= 5.5.28-rel29.3-388.precise) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@precise64:/home/vagrant# aptitude install percona-server-server-5.5 percona-server-client-5.5
The following NEW packages will be installed:
  libaio1{a} libdbi-perl{a} libmysqlclient18{a} libnet-daemon-perl{a}
  libplrpc-perl{a} mysql-common{a} percona-server-client-5.5
  percona-server-common-5.5{ab} percona-server-server-5.5
0 packages upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 34.2 MB of archives. After unpacking 117 MB will be used.
The following packages have unmet dependencies:
 percona-server-common-5.5 : Conflicts: mysql-common but 5.5.29-0ubuntu0.12.04.1 is to be installed.
                             Conflicts: mysql-common:i386 which is a virtual package.
                             Conflicts: mysql-common-4.1 which is a virtual package.
                             Conflicts: mysql-common-4.1:i386 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) libmysqlclient18 [Not Installed]
2) mysql-common [Not Installed]
3) percona-server-client-5.5 [Not Installed]
4) percona-server-server-5.5 [Not Installed]

description: updated
Stewart Smith (stewart) on 2013-01-24
Changed in percona-server:
importance: Undecided → Critical
Ignacio Nin (ignacio-nin) wrote :

Hello,

The bug is confirmed for precise/amd64, although it was fixed in 5.5.29-29.4 so the fix will be out today.

It probably was introduced by the last release of Percona XtraDB Cluster since they share this library, but more info needs to be checked.

Thanks for your report!

Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
status: New → Fix Committed
milestone: none → 5.5.29-30.0
Christopher Kuttruff (chris-k) wrote :

Thanks a lot for the quick response.

Changed in percona-server:
status: Fix Committed → Fix Released
Christopher Kuttruff (chris-k) wrote :

Great; installation now working properly. Thanks again for the prompt update

dgower (truly-anonymous) wrote :

this bug has returned in 5.5.30-rel30.2-500.precise_amd64

Changed in percona-server:
assignee: Ignacio Nin (ignacio-nin) → dgower (truly-anonymous)
tags: added: pkg
Karl Shea (z-karl) wrote :

Confirmed, I can't install Percona at all on a fresh vanilla server install.

Looks like i386 binaries are also affected.

henreich (crutex) wrote :

This bug is still active (13.04)

jason tevnan (jason-tevnan) wrote :

Vanilla ubuntu 12.04 installation fails: Seems to be a failing dependency on percona-server-common-5.5 in connection with libmysqlclient18:

root@vagrant-ubuntu-precise:/etc/chef# apt-cache show percona-server-common-5.5
Package: percona-server-common-5.5
Source: percona-server-5.5
Version: 5.5.30-rel30.2-500.precise
...
Conflicts: mysql-common, mysql-common-4.1, mysql-common-5.0, mysql-common-5.1, percona-server-common-5.1
Replaces: mysql-common, mysql-common-4.1, mysql-common-5.0, mysql-common-5.1, percona-server-common-5.1
Provides: mysql-common

while libmysqlclient18 depends on a version >= 5.5.31-0ubuntu0.12.04.1

root@vagrant-ubuntu-precise:/etc/chef# apt-cache show libmysqlclient18
Package: libmysqlclient18
Priority: optional
Section: libs
Installed-Size: 3282
...
Source: mysql-5.5
Version: 5.5.31-0ubuntu0.12.04.1
Depends: mysql-common (>= 5.5.31-0ubuntu0.12.04.1), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), zlib1g (>= 1:1.1.4)

Dependencies/provides/etc. were always a bit fuzy to me, but i think thats where the problem lies.

Alexey Kopytov (akopytov) wrote :

The problem with this bug reoccurring in recent releases is tracked in bug #1173222.

Changed in percona-server:
assignee: dgower (truly-anonymous) → Ignacio Nin (ignacio-nin)
Changed in percona-server:
status: Fix Released → Confirmed
Ignacio Nin (ignacio-nin) wrote :

Marking this bug (which has resurfaced) as a duplicate of the newer lp:1174271

Changed in percona-server:
status: Confirmed → Fix Released
Pierre (darkstuff) wrote :

I'm experiencing right now this problem on Ubuntu Raring, not Precise

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers