Percona Server with XtraDB

Percona-shared-51 chosen instead of Percona-Server-shared-compat

Reported by Raghavendra D Prabhu on 2012-09-17
30
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.1
High
Ignacio Nin
5.5
High
Ignacio Nin
5.6
High
Ignacio Nin

Bug Description

rpm -qa | grep Percona-Server

    Percona-Server-devel-55-5.5.27-rel28.1.296.rhel6.x86_64
    Percona-Server-server-55-5.5.27-rel28.1.296.rhel6.x86_64
    Percona-Server-shared-55-5.5.27-rel28.1.296.rhel6.x86_64
    Percona-Server-client-55-5.5.27-rel28.1.296.rhel6.x86_64
    Percona-Server-test-55-5.5.27-rel28.1.296.rhel6.x86_64
    Percona-Server-55-debuginfo-5.5.27-rel28.1.296.rhel6.x86_64

sudo yum --disablerepo=ius install perl-DBD-MySQL
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
    --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
    --> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
    --> Running transaction check
    ---> Package Percona-Server-shared-51.x86_64 0:5.1.65-rel14.0.475.rhel6 will be installed
    --> Finished Dependency Resolution

    Dependencies Resolved

    ========================================================================================================================
    Package Arch Version Repository Size
    ========================================================================================================================
    Installing:
    perl-DBD-MySQL x86_64 4.013-3.el6 base 134 k
    Installing for dependencies:
    Percona-Server-shared-51 x86_64 5.1.65-rel14.0.475.rhel6 percona 2.8 M

    Transaction Summary
    ========================================================================================================================
    Install 2 Package(s)

    Total size: 2.9 M
    Installed size: 8.4 M
    Is this ok [y/N]:
    Exiting on user Command

==============
This is clearly incorrect since it should be installing the Percona-Server-shared-compat

Now, this is happening because.

rpm -q --provides Percona-Server-shared-55
    libmysqlclient.so.18()(64bit)
    libtool(/usr/lib64/mysql/plugin/libfnv1a_udf.la)
    libtool(/usr/lib64/mysql/plugin/libfnv_udf.la)
    libtool(/usr/lib64/mysql/plugin/libmurmur_udf.la)
    mysql-shared
    Percona-Server-shared-55 = 5.5.27-rel28.1.296.rhel6
    Percona-Server-shared-55(x86-64) = 5.5.27-rel28.1.296.rhel6

rpm -q --provides Percona-Server-shared-compat
    MySQL-shared
    libmysqlclient.so.12()(64bit)
    libmysqlclient.so.14()(64bit)
    libmysqlclient.so.14(libmysqlclient_14)(64bit)
    libmysqlclient.so.15()(64bit)
    libmysqlclient.so.15(libmysqlclient_15)(64bit)
    libmysqlclient.so.16()(64bit)
    libmysqlclient.so.16(libmysqlclient_16)(64bit)
    libmysqlclient_r.so.12()(64bit)
    libmysqlclient_r.so.14()(64bit)
    libmysqlclient_r.so.14(libmysqlclient_14)(64bit)
    libmysqlclient_r.so.15()(64bit)
    libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
    libmysqlclient_r.so.16()(64bit)
    libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
    mysql-libs
    Percona-Server-shared-compat = 5.5.27-rel28.1.296.rhel6
    Percona-Server-shared-compat(x86-64) = 5.5.27-rel28.1.296.rhel6

rpm -q --provides Percona-Server-shared-51
    MySQL-shared
    Percona-XtraDB-shared
    libmysqlclient.so.16()(64bit)
    libmysqlclient.so.16(libmysqlclient_16)(64bit)
    libmysqlclient_r.so.16()(64bit)
    libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
    mysql-libs
    mysql-shared
    Percona-Server-shared-51 = 5.1.65-rel14.0.475.rhel6
    Percona-Server-shared-51(x86-64) = 5.1.65-rel14.0.475.rhel6

=========

Now, this can cause various problems / conflicts while installation (reported before).

Workaround is to install Percona-Server-shared-compat before installing perl-DBD-MySQL.

Fix: There is duplication between Percona-Server-shared-51 and Percona-Server-shared-compat. Remove Percona-Server-shared-51, keep a single Percona-Server-shared-compat providing libmysqlclient for 12, 14, 15 and 16. If this fix is used, then it will superseded lp:893860 and fix that too.

Tags: pkg Edit Tag help
Ignacio Nin (ignacio-nin) wrote :

The fix for bug lp:1031427 fixes this as well.

Changed in percona-server:
milestone: none → 5.5.30-30.2
Roman Vynar (roman-vynar) wrote :

CentOS 6.4: clean box.

yum --enablerepo=percona install Percona-Server-shared-compat Percona-Server-shared-51 Percona-Server-server-51 Percona-Server-client-51

Installing:
 Percona-Server-client-51 x86_64 5.1.68-rel14.6.551.rhel6 percona 912 k
 Percona-Server-server-51 x86_64 5.1.68-rel14.6.551.rhel6 percona 12 M
 Percona-Server-shared-51 x86_64 5.1.68-rel14.6.551.rhel6 percona 2.8 M
 Percona-Server-shared-compat x86_64 5.5.30-rel30.2.508.rhel6 percona 3.4 M

Transaction Check Error:
  file /usr/lib64/libmysqlclient.so.16.0.0 conflicts between attempted installs of Percona-Server-shared-51-5.1.68-rel14.6.551.rhel6.x86_64 and Percona-Server-shared-compat-5.5.30-rel30.2.508.rhel6.x86_64
  file /usr/lib64/libmysqlclient_r.so.16.0.0 conflicts between attempted installs of Percona-Server-shared-51-5.1.68-rel14.6.551.rhel6.x86_64 and Percona-Server-shared-compat-5.5.30-rel30.2.508.rhel6.x86_64

Is it related?

Alexey Kopytov (akopytov) wrote :

As I understand, Percona-Server-shared-compat is expected to conflict with Percona-Server-shared-51, since they indeed overlap in provided files. What's the purpose of installing them both?

Roman Vynar (roman-vynar) wrote :

Sorry ignore it. In case you need .18.so you can install shared-55, compat is intented to contain older libs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers