Comment 24 for bug 1028240

This bug is present in both upstream versions of shared-compat (5.1 and 5.5):

From MySQL-shared-compat-5.5.28-1.rhel5.x86_64.rpm:

    for x in *;do nm -D $x 2>/dev/null | grep -q CRYPTO_ && echo $x;done
    libmysqlclient.so.15.0.0
    libmysqlclient.so.16.0.0
    libmysqlclient_r.so.15.0.0
    libmysqlclient_r.so.16.0.0

From MySQL-shared-compat-5.1.65-1.rhel5.x86_64.rpm:

    for x in *;do nm -D $x 2>/dev/null | grep -q CRYPTO_ && echo $x;done
    libmysqlclient.so.15.0.0
    libmysqlclient_r.so.15.0.0

Now, the reason why it doesn't crash with mysql-libs is because the only
version of mysql-libs present in rpm repos is mysql-libs-5.1.65 which
doesn't have this issue.

Percona-Server-shared-compat is derived from upstream one, hence it has the same issues.

The 'workaround' is to use Percona-Server-shared-51, however, that is not
possible since Percona-Server-shared-55 and Percona-Server-shared-51
conflict.