libmysqlclient16-dev 'Replaces' libmysqlclient16-dev but doesn't 'Provides' it

Bug #1023883 reported by Christoph Rauch on 2012-07-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
High
Ignacio Nin

Bug Description

Because of this, libmysql++-dev from Debian Squeeze is not installable, because it depends on libmysqlclient15-dev which will in this configuration never get installed, ever. Please add a 'Provides' header to your control file.

Related branches

Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
mickula (mickul-h) wrote :

Any news about this bug?
Any way to workaround it?

Changed in percona-server:
importance: Undecided → High
Changed in percona-server:
status: New → Confirmed
Changed in percona-server:
status: Confirmed → In Progress
Ignacio Nin (ignacio-nin) wrote :

Hello,

The bug is confirmed and its fix will be released in the next Percona-Server 5.1 release.

Unfortunately there doesn't seem to be any direct workarounds, but feel to try the fixed libmysqldev-16 binaries from here: http://www.percona.com/downloads/TESTING/Percona-Server-51/Percona-Server-5.1.63-rel13.4/5.1-bug1023883/446/deb/squeeze/

N.

Changed in percona-server:
status: In Progress → Fix Committed
Stewart Smith (stewart) on 2012-08-27
Changed in percona-server:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-571

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers