Percona Server with XtraDB

mysqld crash message should point to Percona Server bugtracker et al

Reported by Stewart Smith on 2012-06-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server
High
Vadim Tkachenko
5.1
High
Stewart Smith
5.5
High
Vadim Tkachenko

Bug Description

1 === modified file 'Percona-Server/sql/signal_handler.cc'
2 --- Percona-Server/sql/signal_handler.cc 2012-03-06 12:47:57 +0000
3 +++ Percona-Server/sql/signal_handler.cc 2012-05-25 19:45:24 +0000
4 @@ -99,7 +99,9 @@
5 my_safe_printf_stderr("%s",
6 "We will try our best to scrape up some info that will hopefully help\n"
7 "diagnose the problem, but since we have already crashed, \n"
8 - "something is definitely wrong and this may fail.\n\n");
9 + "something is definitely wrong and this may fail.\n"
10 + "Please help us make Percona Server better by reporting any\n"
11 + "bugs at https://bugs.launchpad.net/percona-server\n\n");
12
13 my_safe_printf_stderr("key_buffer_size=%lu\n",
14 (ulong) dflt_key_cache->key_cache_mem_size);
15 @@ -192,9 +194,9 @@
16 my_safe_printf_stderr("Status: %s\n\n", kreason);
17 }
18 my_safe_printf_stderr("%s",
19 - "The manual page at "
20 - "http://dev.mysql.com/doc/mysql/en/crashing.html contains\n"
21 - "information that should help you find out what is causing the crash.\n");
22 + "You may download the Percona Server operations manual by visiting\n"
23 + "http://www.percona.com/software/percona-server/. You may find information\n"
24 + "in the manual which will help you identify the cause of the crash.\n");
25
26 #endif /* HAVE_STACKTRACE */
27

Stewart Smith (stewart) wrote :

Marking as fix released as the correct URLs were in 5.1, just the bug wasn't updated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers