5.5.12 valgrind warnings

Bug #786645 reported by Valentine Gostev on 2011-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
percona-projects-qa
Undecided
Oleg Tsarev

Bug Description

Percona-Server 5.5.12-20.3

list of affected tests in MTR:
main.init_connect
main.percona_bug643149
main.profiling
main.show_profile
main.sp
main.subselect
main.sum_distinct
perfschema.dml_ews_by_instance
main.ctype_cp932_binlog_stm
main.percona_innodb_buffer_pool_shm
main.percona_slow_extended-log_slow_filter
main.percona_slow_extended-microseconds_in_slow_extended
main.percona_slow_extended-min_examined_row_limit
main.percona_slow_extended-long_query_time
main.percona_slow_extended-use_global_long_query_time

Will add other affected tests when another valgrind session completes

Related branches

Valentine Gostev (longbow) wrote :
Changed in percona-projects-qa:
milestone: none → 5.5.12-20.3
Valentine Gostev (longbow) wrote :

Final list is (excluding warnings from upstream):

main.init_connect
main.percona_innodb_buffer_pool_shm
main.percona_slow_extended-log_slow_filter
main.percona_slow_extended-microseconds_in_slow_extended
main.percona_slow_extended-min_examined_row_limit
main.percona_slow_extended-long_query_time
main.percona_slow_extended-use_global_long_query_time
main.percona_bug643149
main.profiling
main.percona_xtradb_bug317074
main.show_profile

Changed in percona-projects-qa:
status: New → Confirmed
Valentine Gostev (longbow) wrote :

valgrind log

Oleg Tsarev (tsarev) on 2011-06-02
Changed in percona-projects-qa:
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
assignee: nobody → Oleg Tsarev (tsarev)
status: Invalid → In Progress
Alexey Kopytov (akopytov) wrote :

"Warnings from upstream" are simply a result of running valgrind tests on a server built without valgrind support.

Oleg Tsarev (tsarev) wrote :

See bugs: #794348 #794350 #794345
This bugs contain descriptions of fails for:
 * main.init_connect
 * main.percona_slow_extended-log_slow_filter
 * main.percona_slow_extended-microseconds_in_slow_extended
 * main.percona_slow_extended-min_examined_row_limit
 * main.percona_slow_extended-long_query_time
 * main.percona_slow_extended-use_global_long_query_time
 * main.profiling
 * main.show_profile

Following fails don't described yet:
 * main.percona_innodb_buffer_pool_shm
 * main.percona_bug643149
 * main.percona_xtradb_bug317074

Oleg Tsarev (tsarev) wrote :

main.percona_bug643149 work fine

Oleg Tsarev (tsarev) wrote :

Splited to several bugs.

#794350 :
 * main.init_connect

#794345:
 * main.percona_slow_extended-log_slow_filter
 * main.percona_slow_extended-microseconds_in_slow_extended
 * main.percona_slow_extended-min_examined_row_limit
 * main.percona_slow_extended-long_query_time
 * main.percona_slow_extended-use_global_long_query_time

#794348:
 * main.profiling
 * main.show_profile

#794366:
 * main.percona_innodb_buffer_pool_shm

Invalid:
 * main.percona_bug643149
 * main.percona_xtradb_bug317074

Changed in percona-projects-qa:
status: In Progress → Incomplete
Oleg Tsarev (tsarev) wrote :

Changed status to "Invalid" because hasn't good description.
Splitted to several bugs.

Oleg Tsarev (tsarev) on 2011-06-08
Changed in percona-projects-qa:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers