Project for Percona QA process

5.1.57 main.percona_slow_extended-slave_innodb_stats fails

Reported by Valentine Gostev on 2011-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
percona-projects-qa
Low
Oleg Tsarev

Bug Description

[root@test-cent5-64-t504 mysql-test]# ./mtr main.percona_slow_extended-slave_innodb_stats
Logging: ./mtr main.percona_slow_extended-slave_innodb_stats
110518 7:53:17 [Note] Flashcache bypass: disabled
110518 7:53:17 [Note] Flashcache setup error is : open flash device failed

110518 7:53:17 [Note] Plugin 'FEDERATED' is disabled.
MySQL Version 5.1.57
Checking supported features...
 - skipping ndbcluster
 - SSL connections supported
Collecting tests...
vardir: /usr/share/mysql-test/var
Checking leftover processes...
Removing old var directory...
Creating var directory '/usr/share/mysql-test/var'...
Installing system database...
Using server port 54552

==============================================================================

TEST RESULT TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
worker[1] mysql-test-run: WARNING: running this script as _root_ will cause some tests to be skipped
main.percona_slow_extended-slave_innodb_stats [ pass ] 4346

MTR's internal check of the test case 'main.percona_slow_extended-slave_innodb_stats' failed.
This means that the test case does not preserve the state that existed
before the test case was executed. Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Logging to '/usr/share/mysql-test/var/tmp/check-mysqld_2.log'.
mysqltest: Results saved in '/usr/share/mysql-test/var/tmp/check-mysqld_2.result'.
mysqltest: Connecting to server localhost:13001 (socket /usr/share/mysql-test/var/tmp/mysqld.2.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /usr/share/mysql-test/var/tmp/check-mysqld_2.result 2011-05-18 06:53:19.645000150 +0300
+++ /usr/share/mysql-test/var/tmp/check-mysqld_2.reject 2011-05-18 06:53:24.192750098 +0300
@@ -1,4 +1,4 @@
-Slave_IO_State
+Slave_IO_State Waiting for master to send event
 Master_Host 127.0.0.1
 Master_User root
 Master_Port 13000
@@ -8,8 +8,8 @@
 Relay_Log_File #
 Relay_Log_Pos #
 Relay_Master_Log_File #
-Slave_IO_Running No
-Slave_SQL_Running No
+Slave_IO_Running Yes
+Slave_SQL_Running Yes
 Replicate_Do_DB
 Replicate_Ignore_DB
 Replicate_Do_Table
@@ -30,7 +30,7 @@
 Master_SSL_Cert
 Master_SSL_Cipher
 Master_SSL_Key
-Seconds_Behind_Master NULL
+Seconds_Behind_Master 0
 Master_SSL_Verify_Server_Cert No
 Last_IO_Errno 0
 Last_IO_Error

mysqltest: Result content mismatch

Changed in percona-projects-qa:
milestone: none → 5.1.57-12.8
Changed in percona-projects-qa:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Oleg Tsarev (tsarev)
Valentine Gostev (longbow) wrote :

With debug binaries:

main.percona_slow_extended-slave_innodb_stats [ fail ] Found warnings/errors in server log file!
        Test ended at 2011-05-20 10:33:26
line
mysqld: ../include/my_dbug.h:39: Dbug_violation_helper::~Dbug_violation_helper(): Assertion `!_entered' failed.
^ Found warnings in /root/Percona-Server-5.1.57/mysql-test/var/log/mysqld.2.err
ok

Changed in percona-projects-qa:
assignee: Oleg Tsarev (tsarev) → Stewart Smith (stewart)
Stewart Smith (stewart) on 2011-05-20
Changed in percona-projects-qa:
assignee: Stewart Smith (stewart) → nobody
Oleg Tsarev (tsarev) on 2011-05-24
Changed in percona-projects-qa:
assignee: nobody → Oleg Tsarev (tsarev)
Oleg Tsarev (tsarev) on 2011-05-25
Changed in percona-projects-qa:
status: Triaged → Fix Committed
Stewart Smith (stewart) on 2011-06-20
Changed in percona-projects-qa:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers