5.5.13 Assertion failure on RPL tests

Bug #781471 reported by Valentine Gostev on 2011-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
percona-projects-qa
High
Laurynas Biveinis

Bug Description

Multiple replication tests fail when we use pool of threads with this assertion failure

110512 1:22:52 InnoDB: Assertion failure in thread 1100896576 in file row0mysql.c line 1133
InnoDB: Failing assertion: trx->mysql_thread_id == os_thread_get_curr_id()
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
110512 1:22:52 - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=1048576
read_buffer_size=131072
max_used_connections=1
max_threads=21
thread_count=1
connection_count=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 10896 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x33d33c0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0x419e5118 thread_stack 0x40000
/root/new_HEAP/sql/mysqld(my_print_stacktrace+0x32)[0x8947c2]
/root/new_HEAP/sql/mysqld(handle_segfault+0x2c8)[0x52af92]
/lib64/libpthread.so.0[0x7f0064cf6b10]
/lib64/libc.so.6(gsignal+0x35)[0x7f00639ea265]
/lib64/libc.so.6(abort+0x110)[0x7f00639ebd10]
/root/new_HEAP/sql/mysqld[0x8dc9c4]
/root/new_HEAP/sql/mysqld[0x8ca038]
/root/new_HEAP/sql/mysqld(_ZN7handler12ha_write_rowEPh+0x53)[0x71d401]
/root/new_HEAP/sql/mysqld(_ZN12ha_partition9write_rowEPh+0x2f2)[0xabff9c]
/root/new_HEAP/sql/mysqld(_ZN7handler12ha_write_rowEPh+0x53)[0x71d401]
/root/new_HEAP/sql/mysqld(_Z12write_recordP3THDP5TABLEP12st_copy_info+0xaa7)[0x5a9cbb]
/root/new_HEAP/sql/mysqld(_Z12mysql_insertP3THDP10TABLE_LISTR4ListI4ItemERS3_IS5_ES6_S6_15enum_duplicatesb+0xb92)[0x5aeede]
/root/new_HEAP/sql/mysqld(_Z21mysql_execute_commandP3THD+0x24ef)[0x5c1c65]
/root/new_HEAP/sql/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x1da)[0x5c6dd2]
/root/new_HEAP/sql/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0xb24)[0x5c837c]
/root/new_HEAP/sql/mysqld(_Z10do_commandP3THD+0x248)[0x5c9848]
/root/new_HEAP/sql/mysqld(libevent_thread_proc+0x211)[0x695771]
/lib64/libpthread.so.0[0x7f0064cee73d]
/lib64/libc.so.6(clone+0x6d)[0x7f0063a8df6d]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0x3419b70): INSERT INTO t1 VALUES (1),(2),(3)
Connection ID (thread ID): 2
Status: NOT_KILLED

description: updated
Changed in percona-projects-qa:
milestone: none → 5.5.13-eb
assignee: nobody → Laurynas Biveinis (laurynas-biveinis)
description: updated
Changed in percona-projects-qa:
status: New → Fix Committed
importance: Undecided → High
Changed in percona-projects-qa:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers