Patches for MySQL by Percona

Crash from failed assertion in dict0dict.c

Reported by macros on 2009-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona-XtraDB
Fix Released
High
Unassigned
Percona patches
Fix Released
High
Unassigned

Bug Description

Server version: 5.0.84-b18-log (MySQL Percona Edition, Revision 57)

Using the same my.cnf we have been using with the ubuntu build 5.0.67, with the exception of adding innodb_dict_size_limit=3221225472

InnoDB: Error: Waited for 590 secs for hash index ref_count (1) to drop to 0.
index: "PRIMARY" table: "halofanon/page_props"
InnoDB: Error: Waited for 595 secs for hash index ref_count (1) to drop to 0.
index: "PRIMARY" table: "halofanon/page_props"
InnoDB: Error: Waited for 600 secs for hash index ref_count (1) to drop to 0.
index: "PRIMARY" table: "halofanon/page_props"
090814 17:08:33InnoDB: Assertion failure in thread 139810549901648 in file dict0dict.c line 1661
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/forcing-recovery.html
InnoDB: about forcing recovery.
090814 17:08:33 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=104857600
read_buffer_size=131072
max_used_connections=1001
max_connections=1000
threads_connected=1001
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 2278400 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd=0x7f2816649800
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
Cannot determine thread, fp=0x7f2816649800, backtrace may not be correct.
Bogus stack limit or frame pointer, fp=0x7f2816649800, stack_bottom=0x7f282e2a0000, thread_stack=131072, aborting backtrace.
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x34ec1ae0 = SELECT /* UnusedimagesPage::recache 127.0.0.1 */ 'Unusedimages' as type, 6 as namespace, img_name as title, img_timestamp as value,
                                img_user, img_user_text, img_description
                                FROM `image` LEFT JOIN `imagelinks` ON img_name=il_to WHERE il_to IS NULL ORDER BY value LIMIT 1000
thd->thread_id=2766510

macros (jasonc-simpleideas) wrote :
macros (jasonc-simpleideas) wrote :

"--skip-innodb-adaptive-hash-index" should avoid the crash....
Please use it when you use innodb_dict_size_limit, until I will fix it.
Thank you

Changed in percona-patches:
status: New → Confirmed
importance: Undecided → Medium
importance: Medium → High

It will be the another assertion errors at XtraDB

Changed in percona-xtradb:
status: New → Confirmed
importance: Undecided → High
Changed in percona-patches:
status: Confirmed → Fix Committed
Changed in percona-xtradb:
status: Confirmed → Fix Committed
Changed in percona-xtradb:
status: Fix Committed → Fix Released
Changed in percona-patches:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers