PCManFM - File Manager

Drag and Drop on desktop not working correctly

Reported by SteVe Cook on 2013-05-12
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
PCManFM
Unknown
Unknown
pcmanfm (Ubuntu)
High
Unassigned

Bug Description

Files on the desktop cannot be dragged into a folder on the desktop. They can, however be dragged from an instance of PCManFM and dropped into a folder on the desktop. See amjjawad's video of this at http://www.youtube.com/watch?v=ix6P6ZwQR-k

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: pcmanfm 1.1.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-1.5-generic 3.9.1
Uname: Linux 3.9.0-1-generic i686
ApportVersion: 2.10-0ubuntu3
Architecture: i386
Config_pcmanfm_System_Lubuntu: Error: [Errno 2] No such file or directory: '/etc/xdg/pcmanfm/lubuntu.conf'
Date: Sun May 12 10:25:06 2013
InstallationDate: Installed on 2012-03-22 (416 days ago)
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Beta i386 (20120301)
MarkForUpload: True
Pref_Config_System_Lubuntu:
 [Preferred Applications]
 WebBrowser=firefox.desktop
 MailClient=
SourcePackage: pcmanfm
UpgradeStatus: Upgraded to saucy on 2013-04-28 (14 days ago)

SteVe Cook (yorvyk) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu):
status: New → Confirmed
amjjawad (amjjawad) wrote :

Thank you so much, Steve Cook :) appreciate that. I was not 100% sure whether I should file this against PCManFM or some other package? you made my day :D

JUST A NOTE:
My system is 13.04 upgraded from raring ringtail beta2 which is upgraded from 12.10 BUT PLEASE NOTE that does not matter. It seems it appears on 13.04 in general. The report shows that this report has been sent from 13.10 so just to make everything is clear, it happened originally in 13.04 and obviously, it is still happening with 13.10 alpha1 :)

I have not tested that on 12.10 to be honest. Not sure if the root of this problem is older than 13.04 and happened before but it does not matter as much as it should be solved very soon. Let's do our best to get rid of this ugly issue before 13.10 so that we be ready for an amazing and rock solid release and YES, I'm talking about 14.04 which is supposed to be LTS :D

Thanks!
http://youtu.be/ix6P6ZwQR-k

sudodus (nio-wiklund) wrote :

I have a few folders on the desktop of my production OS, but I have not tried it when testing.

But now that I know about it I see that this bug affects me too.

It seems that this problem is not exclusive to Lubuntu.
Also tested on two different distros (Puppy and Semplice) with PCManFM and libfm 1.1.0. On both distros drag and drop doesn't work on the desktop. Same issue.

By searching PCManFM GIT logs, I see changes in the drag and drop functions. Also, when there is a problem in these functions, usually affects libfm, not pcmanfm.

Artifact added to PCManFM SourceForge.net bug tracker.

From PCManFM SourceForge.net bug tracker:
Date: 2013-05-21 17:42:41 PDT
Sender: lstranger

Thank you very much for the report. I believe the issue is completely fixed
in GIT repository. The fix touches both libfm and pcmanfm sources and it
will be included into next bugfix version 1.1.1.

Installing libfm and pcmanfm from Git sources, it works:
https://dl.dropboxusercontent.com/u/832939/DnDworks.ogv

Julien Lavergne (gilir) wrote :

Can someone check with 1.1.2 (available in saucy) ? It should be fixed also.

amjjawad (amjjawad) wrote :

Any update regarding this bug???

Also, by any chance, is this bug somehow related to this: https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/891020

Changed in pcmanfm (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
amjjawad (amjjawad) wrote :

Nice, finally some action on this bug :)

Thank you!

Hb (hbb) wrote :

Works now for me under Lubuntu 13.10 with PCManFM 1.1.2-0.

Julien Lavergne (gilir) wrote :

Fixed in 1.1.2

Changed in pcmanfm (Ubuntu):
status: Triaged → Fix Released

fix confirmed at lubuntu 13.10 saucy using PCManFM 1.1.2-0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.