PCB: Printed Circuit Board CAD package

layer with no name causes segfault

Reported by frotz on 2012-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcb
Undecided
Unassigned

Bug Description

If a file contain a layer with a null name, PCB will segfault upon attempting to read the file with no indication as to what the problem is.

frotz (frotz) wrote :

Version of PCB tested was 20091103

Felix Ruoff (felixruoff) wrote :

A fix by Sergey Alyoshin was pushed yesterday. Please test.

Changed in pcb:
status: New → Fix Committed
frotz (frotz) wrote :

Tests okay. Null-named layer appears as "(unknown)". Thanks!

Changed in pcb:
status: Fix Committed → Fix Released
Changed in pcb:
milestone: none → pcb-20140316
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers