pcb

snap to pins and pads does not work when trying to draw line

Bug #884046 reported by Bryan on 2011-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gEDA project
Medium
Unassigned
pcb
Medium
Chad Parker

Bug Description

Try to start drawing a new line with "snap to pads and pins" enabled. The crosshair will not snap to any pins or pads- just to grid points. It does work when the select tool is activated. Also, the arc tool does correctly snap to pads and pins. The problem is just with the line tool. Running version 20110918 on Ubuntu Linux (in Gnome with GTK interface for PCB).

Apparently, the problem does not manifest itself if you are drawing on the
component layer- that works correctly. But try drawing a line on a signal
layer and you run into this problem.

Peter Clifton (pcjc2) wrote :

The line tool should only snap to pads on the layer you are drawing on, so if you are on a signal layer - it would not be expected that the line tool would snap to the location of a pad on the board surface.

Please could you confirm:

1. Whether line tool snapping works on (non top/bottom) signal layers for pins
2. Whether line tool snapping works on (non top/bottom) signal layers for vias

3. Whether the arc tool snapping "works" on (non top/bottom) signal layers for pins or vias.
(If it does, then it is broken!)

Changed in pcb:
status: New → Incomplete
DJ Delorie (djdelorie) wrote :

Another snapping-related bug I've seen recently is this: put a ~geda/0805 down and try to pick it up by the mark. With pad snapping on, it always snaps to one of the two pads, and the cutoff where it decides which one to snap to isn't even centered! Unless you disable snap-to-pad, it's impossible to pick it up by the mark, which is between the two pads.

Ok- I think I see what is going on. The line tool only snaps to objects
in the same "group" as the layer being drawn on?

This seems to be the behavior I am seeing. However, the arc tool snaps
to pins and pads in any group, regardless of
which layer is being drawn on.

1-3: I don't understand the request - what is a non-top/bottom signal
layer? Do you mean signal layers not assigned to the same group as the
"component" or "solder" side of the board?

On 11/12/2011 11:07 AM, Peter Clifton wrote:
> The line tool should only snap to pads on the layer you are drawing on,
> so if you are on a signal layer - it would not be expected that the line
> tool would snap to the location of a pad on the board surface.
>
> Please could you confirm:
>
> 1. Whether line tool snapping works on (non top/bottom) signal layers for pins
> 2. Whether line tool snapping works on (non top/bottom) signal layers for vias
>
> 3. Whether the arc tool snapping "works" on (non top/bottom) signal layers for pins or vias.
> (If it does, then it is broken!)
>
>
> ** Changed in: pcb
> Status: New => Incomplete
>

Peter Clifton (pcjc2) wrote :

That is what I meant, but I think we have enough information to go on now.

It appears the arc tool is not behaving correctly, but the original description of your bug is actually expected behavior.

Traumflug (mah-jump-ing) on 2015-09-27
Changed in geda-project:
importance: Undecided → Medium
Chad Parker (parker-charles) wrote :

My understand of this is that there is a bug in the Arc tool such that it will snap to pads that are on the a different layer from the arc being drawn.

I've fixed this and pushed two commits to LP884046. The first one adds commentary to the snapping routines, the second one fixes the arc bug.

Changed in pcb:
assignee: nobody → Chad Parker (parker-charles)
status: Incomplete → In Progress
Bert Timmerman (bert-timmerman) wrote :

Hi Chad,

It works for arcs and lines, no snapping to pad while laying out traces on an inner layer.

I will cherry-pick the first two commits into master.

It does however snap to pads whilst drawing rectangular polygons.

Maybe we should test for POLYGONPOINT_TYPE ?

Kind regards,

Bert Timmerman.

Changed in pcb:
importance: Undecided → Medium
Changed in pcb:
milestone: none → pcb-4.1.1
Changed in pcb:
status: In Progress → Fix Committed
Changed in pcb:
status: Fix Committed → Fix Released
Changed in geda-project:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers