pcb

windows display bug in 'PCB preferences'

Bug #865951 reported by Tom Pope on 2011-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gEDA project
Medium
Unassigned
pcb
Undecided
Unassigned

Bug Description

I seem to be getting some sort of display bug in the windows build of PCB 20110918 release. This was the one available on DJ's public FTP as gEDA-1.7.1_pcb20110918_GerbV250.zip (download 03-Nov-2011).

Bug Info:
Whenever I open the preferences dialog I can see entries such as 4000.00 mil in (preferences-> sizes->BoardSize ->Width)). Only the number & units are visible, the white text box with up/down arrows is not visible. When I then hover the mouse over the text box (as if to select it), the white text box with up/down arrows appears and the values are not visible any more. Nothing I do can then reveal the value again, making it difficult/impossible to change these values. (see attached jpeg).

It's as if the text box is being rendered on top of the text or the text/box are not refreshing in the right order. I can still 'click' the up/down arrows but it is impossible to see the text. I can manually enter text, causing it to appear momentarily, but it is quickly replaced with the empty white box again.

If I close preferences and re-open I can see the values, but they disappear again when I hover over them.

I've tried:
running as administrator
running in Vista compatibility mode
running in XP SP3 mode

and the bug appears every time.

--------------------------System info---------------------------------------
 MS Windows 7 Professional 32-bit SP1
CPU
 Intel Core i5 760 @ 2.80GHz 38 °C
 Lynnfield 45nm Technology
RAM
 4.00 GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
Motherboard
 ASUSTeK Computer INC. P7P55D-E PRO (LGA1156)
Graphics
 ATI Radeon HD 5700 Series (ASUStek Computer Inc
 512MB GeForce 210 (ASUStek Computer Inc)

-------------------------------------------------------------------------------------
PCB -> Window ->About information:

This is PCB, an interactive
printed circuit board editor
version 20110918

Compiled on Sep 18 2011 at 21:54:23

by harry eaton

----- Compile Time Options -----
GUI:
    gtk : Gtk - The Gimp Toolkit
Exporters:
    bom : Exports a Bill of Materials
    gcode : G-CODE export
    gerber : RS-274X (Gerber) export
    nelma : Numerical analysis package export
    png : GIF/JPEG/PNG export
    ps : Postscript export
    eps : Encapsulated Postscript
Printers:
    lpr : Postscript print

Tom Pope (introcept) wrote :
tags: added: gtk-gui
Peter Clifton (pcjc2) wrote :

It sounds like a GTK bug, but I'm not sure what might cause it.

Could you check whether there is a file "gtkrc" (or similar) in your gEDA install path's etc folder, e.g.?

c:\Program Files\gEDA\etc\gtkrc

If that file is present, it may contain a line setting the use of the Windows theme engine. Remove the file somewhere, and see if that makes the problem go away.

Traumflug (mah-jump-ing) on 2015-09-27
Changed in geda-project:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers