PCB: Printed Circuit Board CAD package

Add plus and minus to possible keyboard-shortcuts

Reported by Felix Ruoff on 2010-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcb
Medium
Andrew Poelstra

Bug Description

Adds the possibility to use plus- and minus-keys for keyboard-shortcuts.

Felix Ruoff (felixruoff) wrote :

I changed my mind about this patch. I think, the keyname translation table should completely be deleted from the code (for code simplification) as suggested in bug LP:700742.

For this reason I canged the status and removed the milestone for this bug.

Changed in pcb:
status: New → Won't Fix
milestone: future-bug-release → none
Peter Clifton (pcjc2) wrote :

Not won't fix please

Changed in pcb:
status: Won't Fix → Confirmed
milestone: none → future-bug-release
Peter Clifton (pcjc2) wrote :

This is a bug, and is succinctlydescribed. "+" and "-" don't work in keyboard shortcuts.

The other suggesion, LP:700742 does not explicity duplicate this report, and whilst application of that patch would cause this bug to be fixed / invalid, until that patch is applied, this bug remains valid.

Please see my comments on the other bug, as to why I think it is not necessarily a good approach.

Felix Ruoff (felixruoff) on 2011-01-30
tags: added: accelerators
Felix Ruoff (felixruoff) wrote :

I have changed my mind again. Since the lesstif-GUI supports those keys as shortcuts, it is a bug, that the GTK-gui does not support them. So, if no more complains, please apply this patch.

Andrew Poelstra (asp11) wrote :

I have added "plus" and "minus" to the keysym table in ghid-main-menu.c.

Changed in pcb:
assignee: nobody → Andrew Poelstra (asp11)
status: Confirmed → Fix Committed
Changed in pcb:
status: Fix Committed → Fix Released
Changed in pcb:
milestone: next-bug-release → pcb-20140316
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers