PCB: Printed Circuit Board CAD package

elements color in manual

Reported by jdlv on 2009-12-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcb
Medium
Unassigned

Bug Description

Pcb manual actualy say:

‘elementColor (color)’
‘elementSelectedColor (color)’
    The elements package part is drawn in these colors, for normal and selected mode, respectively, which both default to XtDefaultForeground.

and :
‘elementColor (color)’
    Elements located on the opposite side of the board are drawn in this color. The default is XtDefaultForeground.

but should be something like:

'InvisibleObjectColor (color)'

http://pcb.gpleda.org/pcb-cvs/pcb.html#index-elementColor-349

Felix Ruoff (felixruoff) wrote :

I did not find any action 'InvisibleObjectColor (color)' in the source-code (did some 'grep's). For this reason, I just fixed the link in the doku and did not add additional documentation.

Changed in pcb:
status: New → Confirmed
Joel Silvestre (j-silvestre) wrote :

Ooups sorry, you can't find it because of a bug in the bug report...

Action is : 'InvisibleObjectsColor'

Now grep find it in the source code.

Felix Ruoff (felixruoff) wrote :

Thanks Joel!
I have found this property but no 'action' to change it. Can you help me finding this action or do the patch yourself?

Joel Silvestre (j-silvestre) wrote :

If I understand correctly 'InvisibleObjectsColor' is not defined as an action but as a resource.

http://pcb.gpleda.org/pcb-cvs/pcb.html#Resources

I think this bug is just a typo, just replace :

`elementColor (color)'
    Elements located on the opposite side of the board are drawn in this color. The default is XtDefaultForeground.

with :

`invisibleObjectsColor (color)'
    Elements located on the opposite side of the board are drawn in this color. The default is XtDefaultForeground.

As an example follows the settings file I use :

cat .pcb/settings

media = A4
background-color = #000000
crosshair-color = #304020
element-color = #505020
invisible-objects-color = #608030
layer-color-1 = #FF0000
layer-color-2 = #E34000
layer-color-3 = #D94C00
layer-color-4 = #0000FF
layer-color-5 = #0051FF
layer-color-6 = #0077FF
layer-color-7 = #7F6167
layer-color-8 = #6A617F
selected-color = #302040
via-color = #404040
pin-color = #404040

Felix Ruoff (felixruoff) wrote :

Now, I found this, thanks!
Have done a new patch.

Changed in pcb:
status: Confirmed → Fix Committed
Peter Clifton (pcjc2) on 2011-09-21
Changed in pcb:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers