pcb

Draw w/auto drc during DRC causes crash

Bug #699284 reported by Ben Jackson on 2009-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gEDA project
Critical
Unassigned
pcb
Medium
Unassigned

Bug Description

DRC uses InitConnectionLookup() to allocate some (global) memory. When it pauses to show you a DRC error it is possible to cause a InitConnectionLookup/FreeConnectionLookupMemory pair which will cause the DRC to crash when it resumes. The easiest way to do this is to be in line drawing mode when you start the DRC and then inadvertently click when the cursor is warped to the problem location. If AutoDRC is on, a LookupConnection will be initiated to find what net you are drawing on. That will trigger the init/free. When you click 'next' in the DRC dialog PCB will crash.

It looks like the only safe way to handle this is to free before the DRC dialog and init again after. There could be more objects after the dialog, after all.

Traumflug (mah-jump-ing) on 2015-09-27
Changed in geda-project:
importance: Undecided → Critical
Traumflug (mah-jump-ing) wrote :

Trying with current Git master I can't reproduce this bug. Looking at the age of the bug it may well have been fixed already. If the bug persists, please open a new one with a test case.

Changed in geda-project:
status: New → Fix Released
tags: added: crash drc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers