pcb

OSX: GL displays garble in both 2D and 3D

Bug #1542882 reported by Chad Parker on 2016-02-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcb
Low
Unassigned

Bug Description

On OSX 10.10, everything in the canvas is garbled. Compiled from git on 20160205. All of the GTK buttons and things are displayed fine, only the PCB canvas is garbled. In the console the following errors are thrown any time the canvas is redrawn:

No stencil bits available.
Cannot mask polygon holes or subcomposite layers
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned
No more stencil bits available, total of 0 already assigned

Screenshot: https://drive.google.com/file/d/0B3k6ZsL60zPuNzBHVU54QUs0X0k/view?usp=sharing

Compiling without GL, the canvas displays fine in 2D.

Tags: osx Edit Tag help
tags: added: osx
Chad Parker (parker-charles) wrote :

I'm not exactly sure what I did or when I fixed this, but I can no longer reproduce this. Seeing as how no one else has reported that this affects them, I'd say we should just close it.

Bert Timmerman (bert-timmerman) wrote :

Hi Chad,

There is another bug report, filed on 05-feb-2016, (https://bugs.launchpad.net/pcb/+bug/1542859) which might be affected by a faulty build process on OSX (due to whatever reason).

Could you please check if the above mentioned bug still exists.

Thanks and kind regards,

Bert Timmerman

Changed in pcb:
status: New → Invalid
Changed in pcb:
milestone: none → future-bug-release
importance: Undecided → Low
status: Invalid → Triaged
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers