pcb

Polygons editing in `Thin draw' mode

Bug #1084475 reported by Eugene Mikhantiev
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gEDA project
Confirmed
Medium
Unassigned
pcb
New
Undecided
Unassigned

Bug Description

`Insert' tool does not do anything in `Thin draw' or `Thin draw poly' modes when I try to insert a new vertex to polygon. Also I can't drag existed vertexes or selected polygons with `select' tool.

PCB from git master branch.

Tags: polygons
Revision history for this message
Peter Clifton (pcjc2) wrote :

This was a deliberate design decision (possibly not a good one), but I can confirm that the behaviour is known and expected.

I'm not familiar with the reasoning behind the choice though.

Revision history for this message
Eugene Mikhantiev (mehanik) wrote :

If so, then instruction http://wiki.geda-project.org/geda:pcb_tips#how_do_i_edit_polygons must be corrected, because it says: ``Polygons can be edited equally well in “thin line draw” mode (Settings → Thin draw poly) or in normal mode''.

Revision history for this message
Peter Clifton (pcjc2) wrote :

Hmm, perhaps this has changed.

The behaviour I see is somewhat inconsistent.

I know it is deliberate that you cannot click and grab to move a polygon when in thin-draw mode, but you CAN drag existing vertices arount in git HEAD.

I can confirm that the insert node tool doesn't work in thindraw modes.

Traumflug (mah-jump-ing)
Changed in geda-project:
importance: Undecided → Medium
status: New → Confirmed
tags: added: polygons
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers