`jostle' plugin incompatible with new PCB HID API

Bug #1080629 reported by Eugene Mikhantiev
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pcb-plugins
Fix Committed
High
Bert Timmerman

Bug Description

PCB HID API changed in upstream PCB commit 73b243d90cda84e09f52b7ff995fa82afdc3de0

Fix that makes jostle plugin works with new PCB HID API. Obviously, it is not compatible with the stable version of PCB.

Revision history for this message
Eugene Mikhantiev (mehanik) wrote :
Changed in pcb-plugins:
assignee: nobody → Bert Timmerman (bert-timmerman)
importance: Undecided → Medium
status: New → In Progress
Changed in pcb-plugins:
status: In Progress → Fix Committed
importance: Medium → High
milestone: none → 0.0.3
summary: - `jostile' plugin incompatible with new PCB HID API
+ `jostle' plugin incompatible with new PCB HID API
Revision history for this message
Eugene Mikhantiev (mehanik) wrote :

In upstream pcb commit dc0092500ad8b6a3c9c35aef63eda9ad1cb2a2cb HID drawing API was moved to separate file `hid_draw.h', so it must be included.

Changed in pcb-plugins:
status: Fix Committed → Triaged
Changed in pcb-plugins:
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers