Decompress from STDIN

Bug #820525 reported by Peter on 2011-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pbzip2
Low
Yavor Nikolov

Bug Description

Is it possible to implement decompressing from STDIN? Or is this not possible or has no practical value? Or is this already implemented somehow and needs more documentation (I couldn't figure it out)?

Thanks!

Peter (chinasaurli) wrote :

Hmmm, based on Yavor's contribution list in pbzip2.cpp version 1.1.5 it sounds like this is already implemented:

"Signalling error on stdin decompression when file doesn't start with correct bzip2 magic header"

"Handle decompression of very long bz2 streams incrementally instead of loading whole streams in memory at once"

I'll poke around and see if I can figure it out, but maybe some more documentation is called for. Thanks!

Peter (chinasaurli) wrote :

Okay, turned out it was simple and I was just mistakenly calling 1.0 on my system instead of the 1.1.5 that I had built. But documentation of this feature would still be nice. Thanks!

Changed in pbzip2:
importance: Undecided → Low
Yavor Nikolov (yavor-nikolov) wrote :

Perhaps we should add a statement like this:
"If no file names are given, pbzip2 compresses or decompresses from standard input to standard output. "
to the man page and to the help message.

Changed in pbzip2:
status: New → Confirmed
Peter (chinasaurli) wrote :

That would be nice. I think adding an example that uses STDIN would be the most straightforward way to document.

Would also be helpful if the changelog made it more clear when this became available since my original version was 1.0 and didn't have this.

Changed in pbzip2:
milestone: none → 1.1.6
assignee: nobody → Yavor Nikolov (yavor-nikolov)
status: Confirmed → Fix Committed
Changed in pbzip2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers