Intermittent crash on compression / OS X

Bug #1399589 reported by Ryan Schmidt on 2014-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pbzip2
High
Unassigned

Bug Description

pbzip2 intermittently crashes upon decompressing bz2 files, even ones it itself created just moments before. Retrying works without a crash.

The MacPorts package management system stores all installed packages as tar.bz2 archives, and was recently enhanced to support creating and decompressing these using pbzip2, if it happens to be installed with MacPorts. It is on my system, and though it usually works fine, the number of times it does not is greater than 0, which results in failure to install whatever package I'm currently trying to install.

I'm attaching two OS X crash logs of this situation that I experienced today. Let me know if you need any further info to diagnose this.

Related branches

Ryan Schmidt (z-launchpad-d) wrote :
Ryan Schmidt (z-launchpad-d) wrote :
Yavor Nikolov (yavor-nikolov) wrote :

Hi Ryan, thanks for reporting that issue.
Unfortunately I have no OS X to test with right no. Would you be able to comple pbzip2 in debug mode and reproduce the issue with it. (It would be helpful to have the debug output)?

Ryan Schmidt (z-launchpad-d) wrote :

I can certainly compile it in debug mode, if you'll tell me what flags or environment variables to compile with to accomplish that, and if the issue occurs again I can send you whatever information is produced.

Yavor Nikolov (yavor-nikolov) wrote :

Just take uncomment following in Makefile and compile it:
CXXFLAGS += -DPBZIP_DEBUG

Ryan Schmidt (z-launchpad-d) wrote :

Thanks; done. I reproduced the crash today; here's the relevant part of the MacPorts log. I was mistaken: it crashes when compressing, not when decompressing.

Changed in pbzip2:
status: New → In Progress
milestone: none → 1.1.11
assignee: nobody → Yavor Nikolov (yavor-nikolov)
importance: Undecided → High
summary: - Intermittent crash on decompression
+ Intermittent crash on compression / OS X
Yavor Nikolov (yavor-nikolov) wrote :

Hi Ryan, would you be able to test if the following patched version solves the issue: https://code.launchpad.net/~pbzip2/pbzip2/bug-1399589-crash-on-compress-on-os-x

Changed in pbzip2:
status: In Progress → Fix Committed
Changed in pbzip2:
assignee: Yavor Nikolov (yavor-nikolov) → nobody
milestone: 1.1.11 → none
status: Fix Committed → Fix Released
Ryan Schmidt (z-launchpad-d) wrote :

Thanks. I haven't seen the crash again since applying your fix on the 7th.

Yavor Nikolov (yavor-nikolov) wrote :

Great. Thanks for your feedback!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers