Row-based Replication (RBR) fails if primary keys are not on all tables

Bug #430716 reported by Paul McCullagh
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
PBXT
Fix Committed
Undecided
Vladimir Kolesnikov

Bug Description

RBR aborts almost immediately, apparently because the tests don't necessarily have a PK on each table (it works for InnoDB though).

Related branches

Changed in pbxt:
assignee: nobody → Vladimir Kolesnikov (vkolesnikov)
status: New → In Progress
Revision history for this message
Vladimir Kolesnikov (vkolesnikov) wrote :

We decided to not fix this bug at least now. The reason is that according to our internal and external tests the problem occurs only on one specific alpha release of MySQL (6.0.9) and it can be reproduced for InnoDB as well. Thus we conclude that the problem is not PBXT-specific. We have added a test (rpl_for_pbxt3) that covers this case.

Changed in pbxt:
status: In Progress → Incomplete
status: Incomplete → Invalid
Revision history for this message
Paul McCullagh (paul-mccullagh) wrote :

I am flagging this bug as "fix committed" rather than "won't fix", but either would apply.

A test case has been added which runs without error using MySQL 5.1. So any regress will be noticed.

As mentioned before, the test case fails under 6.0.9, but this is not considered a PBXT specific problem.

Changed in pbxt:
status: Invalid → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers