PBR

Comment 8 for bug 1453996

Ebbex (eb4x) wrote :

I think we've run into this issue recently;

Oct 20 15:49:53 Collecting networking_calico from git+file:///var/www/repo/openstackgit/networking-calico@79bdf4995d102833d23479180350216fc59e4b94#egg=networking_calico&gitname=networking-calico&projectgroup=neutron_all (from -c /var/www/repo/os-releases/18.1.13.dev3/ubuntu-18.04-x86_64/requirements_constraints.txt (line 24))
163 Oct 20 15:49:53 Cloning file:///var/www/repo/openstackgit/networking-calico (to revision 79bdf4995d102833d23479180350216fc59e4b94) to /tmp/openstack-builder/networking-calico
164 Oct 20 15:49:53 Complete output from command python setup.py egg_info:
165 Oct 20 15:49:53 ERROR:root:Error parsing
166 Oct 20 15:49:53 Traceback (most recent call last):
167 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/core.py", line 96, in pbr
168 Oct 20 15:49:53 attrs = util.cfg_to_args(path, dist.script_args)
169 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/util.py", line 259, in cfg_to_args
170 Oct 20 15:49:53 pbr.hooks.setup_hook(config)
171 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/hooks/__init__.py", line 25, in setup_hook
172 Oct 20 15:49:53 metadata_config.run()
173 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/hooks/base.py", line 27, in run
174 Oct 20 15:49:53 self.hook()
175 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/hooks/metadata.py", line 26, in hook
176 Oct 20 15:49:53 self.config['name'], self.config.get('version', None))
177 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/packaging.py", line 824, in get_version
178 Oct 20 15:49:53 version = _get_version_from_git(pre_version)
179 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/packaging.py", line 764, in _get_version_from_git
180 Oct 20 15:49:53 result = _get_version_from_git_target(git_dir, target_version)
181 Oct 20 15:49:53 File "/openstack/venvs/repo-build-18.1.13.dev3/local/lib/python2.7/site-packages/pbr/packaging.py", line 726, in _get_version_from_git_target
182 Oct 20 15:49:53 dict(new=new_version, target=target_version))
183 Oct 20 15:49:53 ValueError: git history requires a target version of pbr.version.SemanticVersion(3.9.2), but target version is pbr.version.SemanticVersion(3.8.4)
184 Oct 20 15:49:53 error in setup command: Error parsing /tmp/openstack-builder/networking-calico/setup.cfg: ValueError: git history requires a target version of pbr.version.SemanticVersion(3.9.2), but target version is pbr.version.SemanticVersion(3.8.4)
185 Oct 20 15:49:53
186 Oct 20 15:49:53 ----------------------------------------
187 Oct 20 15:49:54 Command "python setup.py egg_info" failed with error code 1 in /tmp/openstack-builder/networking-calico/
188

Looking at the git state in networking-calico;

$ git log
commit 79bdf4995d102833d23479180350216fc59e4b94 (HEAD -> master, tag: 3.9.2, tag: 3.9.1, tag: 3.9.0, tag: 3.8.4, tag: 3.8.3, tag: 3.8.2, origin/master, origin/HEAD)

$ git tag
[...]
3.8.0
3.8.2
3.8.3
3.8.4
3.9.0
3.9.1
3.9.2

$ git describe
3.8.4

$ git describe --long
3.8.4-0-g79bdf49

https://zuul.opendev.org/t/openstack/build/95c59b998d2947ebac4fd08cafe1400b/log/logs/openstack/aio1_repo_container-9cf59a00/repo/wheel_build.log.txt.gz#162