Encoding issues in translations

Bug #350989 reported by Loïc Minier on 2009-03-29
52
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Payson
Undecided
Unassigned
Ubuntu Netbook Remix Launcher
Undecided
Unassigned
buffalo
Medium
Unassigned
kubuntu-meta (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
netbook-launcher (Ubuntu)
High
Steve Kowalik
Jaunty
High
Steve Kowalik

Bug Description

Hi

When using UNR in French, "Network" on the right is displayed as "Réseau" instead of "Réseau". This is double-encoded UTF-8:
% echo Réseau | iconv -f iso-8859-1 -t utf-8
Réseau

This is actually an error in the po/*.po files which affects a bunch of strings, and not only French.

I traced this to commit knitzsche@chroma-20090306155513-7qabqocyf7secthd:
    revno: 217.1.1
    committer: knitzsche <knitzsche@chroma>
    branch nick: trunk
    timestamp: Fri 2009-03-06 10:55:13 -0500
    message:
      * po/LINGUAS: corrected alphabetization error in codes
      * po/*.po: integrated unr 1.2 translations

I can confirm that this commit broke random strings in fr.po and seemingly in plenty of other languages.

Bye

Related branches

Loïc Minier (lool) wrote :

I don't if they are any legitimate updates to translated strings in the problematic bzr revision, nor whether any other commits had similar issues. If it's the only commit with this issue and if no existing string was intended to be changed in this commit (but the only intent was to translate missing/empty strings), then I recommend reverting the changes to existing strings in that commit.

Otherwise, we could either try to double UTF-8 decode all strings and keep the last version which decodes as UTF-8; we face the risk that some UTF-8 string encodes as valid UTF-8.

Changed in netbook-launcher:
importance: Undecided → High
milestone: none → ubuntu-9.04
Adi Roiban (adiroiban) on 2009-03-30
tags: added: i18n
Kyle Nitzsche (knitzsche) wrote :

Yes, the po files for this translation update appear to contain many non-UTF-8 encoded characters. I'll have to determine the source and rectify this.

Kyle Nitzsche (knitzsche) wrote :

I see that the fr.po file I gave to the translators (third-party, not LP) contained this:

#: ../src/launcher-sidebar.c:479 ../src/launcher-sidebar.c:1114
msgid "Network"
msgstr "Réseau

Whereas the fr.po file returned contained this:
#: ../src/launcher-sidebar.c:479 ../src/launcher-sidebar.c:1114

msgid "Network"

msgstr "Réseau"

Kyle Nitzsche (knitzsche) wrote :

I have contacted the third-party translators and have requested corrected files.

I have re-iterated to them the critical necessity of only using tools that support utf-8 encoding natively.

Steve Langasek (vorlon) on 2009-03-30
Changed in netbook-launcher:
status: New → Triaged
Kyle Nitzsche (knitzsche) wrote :

The third-party translators have said they will provide corrected po files ASAP, probably mar 31.

Peter Magnusson (kmpm) wrote :

This is the same for swedish. The translation for Network which should be Nätverk is translates to Nätverk.
Same symptoms for "Add to favourites" which should be "Lägg till i favoriter" but is "Lägg till i favoriter"

So far it's only the swedish letter "Ä" that I have found to be wrong and this in several places like described above.

Kyle Nitzsche (knitzsche) wrote :

I have the corrected po files and have attached them as two tarballs, one for netbook-launcher, one for window-picker-applet. (Including w-p-a because the third-party translators also updated those and may have made the same mistake -- even though no one has noticed an encoding bug in this pkg, it is better to be safe.)

I am not sure what the appropriate path is for integrating them. Please advise.

Kyle Nitzsche (knitzsche) wrote :
Kyle Nitzsche (knitzsche) wrote :

I pushed a new bzr branch with corrected po files to lp:~netbook-remix-team/netbook-remix-launcher/trunk

Neil will pkg for Jaunty, Intrepid and Hardy.

Kyle Nitzsche (knitzsche) wrote :

Also bzr pushed window-picker-applet/trunk to replace its po files, which were also handled by the third-party translators, may have had encoding errors, and have been fixed by them.

Neil J. Patel (njpatel) wrote :

Kyle has updated the launcher with fixed translations (window-picker-applet too), and I've rolled a new release of both projects. I've notified Steven K., and hopefully we'll get updated debs in Jaunty sometime tomorrow.

Changed in netbook-remix-launcher:
status: New → Fix Committed
Loïc Minier (lool) wrote :

Jeff, how does it affect kubuntu-meta?

Steve Langasek (vorlon) on 2009-04-02
Changed in netbook-launcher (Ubuntu Jaunty):
assignee: nobody → stevenk
Loïc Minier (lool) on 2009-04-03
Changed in kubuntu-meta (Ubuntu Jaunty):
status: New → Invalid
Steve Langasek (vorlon) wrote :

netbook-launcher was uploaded on April 4. This bugfix wasn't mentioned in the bug log, but I've confirmed that the French .po file included in the upload is correctly encoded.

Changelog entry:

netbook-launcher (1.6.19-0ubuntu1) jaunty; urgency=low

  * New upstream release.
    - Changes Quit icon. (LP: #354003)

 -- Steve Kowalik <email address hidden> Sat, 04 Apr 2009 14:06:30 +1100

Changed in netbook-launcher (Ubuntu Jaunty):
status: Triaged → Fix Released
Bill Filler (bfiller) wrote :

translations fixed with new netbook-launcher and window-picker-applet

Changed in buffalo:
importance: Undecided → Medium
milestone: none → m3
status: New → Fix Committed
Tom Halchuk (tomhal) wrote :

Build Version 20090504-M3 Date: 20090504-M3 Buffalo
Environment used for testing:
BIOS 1.30.1BT

Verified Fixed

Anmar Oueja (anmar) on 2009-05-05
Changed in buffalo:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2009-08-14
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers