text under icons wraps badly in netbook-launcher

Bug #277133 reported by Rachel Greenham on 2008-10-02
8
Affects Status Importance Assigned to Milestone
Payson
Wishlist
Unassigned
Ubuntu Netbook Remix Launcher
High
miquel
netbook-launcher (Ubuntu)
Low
miquel

Bug Description

ume-launcher word-wraps the names of applications in the central pane somewhat eccentrically. Specifically the OpenOffice.org applications. See screenshot.

eg:

OpenOffice.or
g Word
Processor

It seems that the wordwrap code needs to be a bit more sensitive to punctuation. For instance, if it was set to prefer to split on (before) a punctuation mark over splitting between two consecutive same-case letters, you might get:

OpenOffice
.org Word
Processor

I wouldn't be surprised if I'm getting this due to my taste in fonts, but surely the wordwrap algorithm should cope with that? :-)

Another example, although a punctuation-preferring rule won't help here, is in my Preferences menu, where I see

Keyboar
d
Shortcuts

Is there not some general text wordwrap/hyphenation code in gnome that might be applied here? Or is it being, and failing?

Neil J. Patel (njpatel) wrote :

We do use Pango and set wrapping to PANGO_WRAP_WORD_CHAR, which should try and wrap on word and, if the fails, wrap on char. Unfortunately the character wrapping doesn't use hyphens and, it seems, doesn't look for 'good' points to wrap (such are the '.' in the OO.org example).

The WORD_CHAR wrapping was introduced to fix issues in non-english locales such as German and Swedish, where the words are very long an would be cut off.

Changed in netbook-remix:
assignee: nobody → njpatel
importance: Undecided → High
status: New → Confirmed

This doesn't seem to be an issue in Intrepid. I'd guess bugs fixed in pango upstream?

An associated bug still exists - not sure if it warrants a new bug report as the title to this one fits it well. And that's the launch notification thing that pops up when something is launched from the netbook-launcher. The name of the application is shown, but it overflows the box it's supposed to be in, rather than being word-wrapped with it.

Screenshot attached.

Neil J. Patel (njpatel) wrote :

I just fixed the notification window word-wrap issue (for hardy, intrepid will follow later this week).

Interesting wrt this not being a problem on hardy. I don't think Pango has changed enough to fix this...maybe it's a ClutterLabel bug? I'll see if I can get anything from the Clutter devs.

Neil J. Patel (njpatel) wrote :

I, of course, meant "not being a problem on Intrepid" :-)

Neil J. Patel wrote:
> Interesting wrt this not being a problem on [intrepid]. I don't think Pango
> has changed enough to fix this...maybe it's a ClutterLabel bug? I'll see
> if I can get anything from the Clutter devs.
>

As long as bringing it to their attention doesn't make them break it
again. ;-)

I'll *try* to wait for the latest fix on intrepid. :-P

"I just fixed the notification window word-wrap issue (for hardy, intrepid will follow later this week)."

bump! Doesn't look like this happened - latest netbook-launcher on intrepid (1.4.0~ppa1) just installed doesn't have this fix. :-)

David Chen (david.chen) on 2008-10-22
Changed in payson:
status: New → Confirmed
Changed in payson:
importance: Undecided → Wishlist
Neil J. Patel (njpatel) wrote :

Sorry about that, netbook-launcher_1.5.0 has the notification window issues.

Also, I'd like to confirm Rachel's findings that the character wrap issue only seems to exist in ume-launcher (clutter-0.6, hardy pango). Netbook launcher character wrapping seems to happen at "correct" points in a sentence, namely '-' or '.' first, before resorting to the middle of a word.

Neil J. Patel (njpatel) on 2008-11-10
Changed in netbook-remix-launcher:
milestone: none → 2.0
Torsten Spindler (tspindler) wrote :

This will not be addressed in the final image, target is an update.

Changed in payson:
milestone: none → maintenance
Liu shu (shu-liu) wrote :

Still open in 11/25 image

miquel (cmiquel225) on 2009-04-08
summary: - ume-launcher application name wordwrap issue
+ actualization
Changed in netbook-remix-launcher:
assignee: njpatel → cmiquel225
status: Confirmed → New

Moving to Ubuntu distribution

Changed in netbook-launcher (Ubuntu):
assignee: nobody → miquel (cmiquel225)
importance: Undecided → High
Changed in netbook-remix-launcher:
status: New → Won't Fix
tags: added: ubuntu-unr
Paul Larson (pwlars) wrote :

Can this be closed for netbook-launcher and stay open for a Payson update if needs be? I've been unable to reproduce this in karmic so far. Also setting importance to Low since it is a cosmetic issue.

Changed in netbook-launcher (Ubuntu):
importance: High → Low
status: New → Triaged
summary: - actualization
+ text under icons wraps badly in netbook-launcher

This is definetly fixed in the latest karmic. Marking as fix released.

Changed in netbook-launcher (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers