Fix up flavor_rxtx RBAC tests

Bug #1712725 reported by Felipe Monteiro on 2017-08-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Patrole
Medium
Samantha Blanco

Bug Description

flavor_rxtx compute tests should be re-written to offer coverage for the APIs listed in [0] and should check for the existence of the key in the response body or else raise a RbacMalformedResponse Exception.

[0] https://github.com/openstack/nova/blob/33d25faa9c8d793325afc681945b840e7062d6a4/nova/policies/flavor_rxtx.py

Felipe Monteiro (fm577c) on 2017-08-24
Changed in patrole:
importance: Undecided → Medium
status: New → Confirmed
Changed in patrole:
assignee: nobody → Samantha Blanco (sblanco1)

Fix proposed to branch: master
Review: https://review.openstack.org/498051

Changed in patrole:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/498051
Committed: https://git.openstack.org/cgit/openstack/patrole/commit/?id=bf58a7fe3a2e03a60d4142b28b831663ddaf7b68
Submitter: Jenkins
Branch: master

commit bf58a7fe3a2e03a60d4142b28b831663ddaf7b68
Author: Samantha Blanco <email address hidden>
Date: Fri Aug 25 14:21:49 2017 -0400

    Fix flavor_rxtx_rbac

    Updates flavor_rxtx to more thoroughly test policy enforcement
    by
    - making use of RbacMalformedResponse to ensure rxtx_factor
      is included in response body
    - adding new flavor_rxtx tests

    Currently, POST /flavors is not tested as that action also
    enforces os-flavor-manage: create, which is admin-only by
    default and would therefore fail due to conflicting policy
    restrictions. This test will be added once multi-policy
    support is available.

    Change-Id: I7fb35212fc6bb817a2b04077c983865e1191f214
    Closes-Bug: #1712725

Changed in patrole:
status: In Progress → Fix Released

This issue was fixed in the openstack/patrole 0.3.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers