Use Granite's dynamic notebook for tab bar

Bug #948276 reported by Sergey "Shnatsel" Davidoff on 2012-03-06
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Wishlist
Julián Unrrein
Midori Web Browser
Fix Released
Undecided
Unassigned
Scratch
Fix Released
Wishlist
Mario Guerriero
Terminal
Fix Released
Medium
Tom Beckmann

Bug Description

Just what it says on the tin. Use Granite's dynamic notebook widget for tab bar.

Related branches

Changed in pantheon-terminal:
milestone: none → 0.1
Changed in scratch:
milestone: none → luna-beta1
status: New → Confirmed
importance: Undecided → Medium
tags: added: consistency
Changed in pantheon-terminal:
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in midori:
status: New → Confirmed
tags: added: granite
Changed in pantheon-terminal:
importance: Undecided → Medium
status: New → Confirmed
Changed in pantheon-terminal:
assignee: Mario Guerriero (mefrio-g) → nobody
Changed in scratch:
assignee: nobody → Andrea Basso (voluntatefaber)
Mario Guerriero (mefrio-g) wrote :

Andrea don't forget to take in consideration the xapantu's branch :)

Andrea Basso (voluntatefaber) wrote :

Yeah, I haven't seen it. Since he's already working on that I've unassigned myself

Changed in scratch:
assignee: Andrea Basso (voluntatefaber) → nobody
Changed in midori:
status: Confirmed → In Progress
Changed in pantheon-terminal:
assignee: nobody → Mario Guerriero (mefrio-g)
status: Confirmed → In Progress
Andrea Basso (voluntatefaber) wrote :

Since we're past feature freeze and Dynamic Notebook itself isn't mature enough, adding it shouldn't be targeted to luna-beta1 (this decision was shared with Dan)

Changed in pantheon-terminal:
milestone: luna-beta1 → none
Changed in scratch:
milestone: luna-beta1 → none
Christian Dywan (kalikiana) wrote :

For all practical purposes, Midori supports Granite, and individual issues are being tracked in separate reports.

Changed in midori:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-07-22
Changed in pantheon-terminal:
status: In Progress → Fix Committed
assignee: Mario Guerriero (mefrio-g) → Tom Beckmann (tombeckmann)
milestone: none → luna-beta1
Daniel Fore (danrabbit) on 2012-07-26
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2012-08-12
Changed in pantheon-files:
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → Wishlist
tags: added: dynamic-notebook tabs
Changed in scratch:
assignee: nobody → elementary UX Team (elementary-design)
Daniel Fore (danrabbit) wrote :

For Scratch the decision was made to wait until the dynamic notebook matures in it's implementation enough to support all of Scratch's needs. So likely this will be a post-Luna item for Scratch.

Changed in scratch:
assignee: elementary UX Team (elementary-design) → nobody
importance: Medium → Wishlist

I've posted some thoughs on using DynamicNotebook in Scratch at http://shnatsel.blogspot.com/2012/08/idea-dump-todo-list.html

Or maybe new tab should just show a welcome screen and the welcome screen should be improved.

Changed in midori:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2013-02-06
Changed in pantheon-files:
milestone: none → 0.2
Changed in scratch:
assignee: nobody → Mario Guerriero (mefrio-g)
milestone: none → 2.0
status: Confirmed → Fix Released
Changed in pantheon-files:
assignee: nobody → Julián Unrrein (junrrein)
status: Triaged → In Progress
Cody Garver (codygarver) wrote :

Can I just say, AAAAAHHHHHHHH dynamicnotebook is propagated everywhere now!!

Changed in pantheon-files:
milestone: 0.2 → luna-rc1
status: In Progress → Fix Released
Julián Unrrein (junrrein) wrote :

Who would say, that this day finally came :) Keep going guys!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers